WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
[resolved] 'Rewrite' => array( 'slug' => 'new slug' ) is NOT working becau (2 posts)

  1. JennGrahamUNC
    Member
    Posted 1 year ago #

    Before I added the Yoast SEO plugin, I had changed the slug to my portfolio page to read "Speakers" - below is the change I made:

    In theme-posttypes.php, Changed to this:

    'rewrite' => array( 'slug' => 'speakers' ),

    Then I saved my permalink setting to flush out the old rules and prevent 404 errors for the pages.

    And since then, my links were: http://www.colabsummit.com/speakers/blah-blah

    But now that Yoast SEO was added, the links went back to their original slug names, ignoring the code change. Now they read: http://www.colabsummit.com/portfolio/blah-blah

    I need to switch it back to just "speakers" — so what do I need to do to disable whatever change SEO Yoast made?

    Thanks!

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. JennGrahamUNC
    Member
    Posted 1 year ago #

    Nevermind!

    I figured it out. There were two backslashes before that line of code. I deleted them, and now it's working.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic