WordPress.org

Ready to get started?Download WordPress

Forums

GamePress
[resolved] Reviews Not Appearing on Home Page (3 posts)

  1. gahoo
    Member
    Posted 1 year ago #

    Fantastic theme Alex - and great support here on the boards. Everything works perfectly for us save 2 (unrelated) issues. We're running a slightly modified version of GamePress 0.9.

    At issue here is that we can't get the reviews to show up in the main loop. The boxes are checked in the theme options.

    As an aside, we exclude two categories from showing on the main loop, but have otherwise not touched the loop. We removed the filter to test but doing so had no effect. Loop is posted below in case it helps.

    Any advice? I posted a test review just now on 12/20 for testing purposes.

    Site is http://gamerescape.com/

    The Loop

    <?php
    query_posts($query_string . '&cat=-1970,-1971');
    //query_posts($query_string );
    if ( have_posts() ) : while ( have_posts() ) : the_post();
    <div class="post">
    /**<!-- Display the Title as a link to the Post's permalink. -->
    */
    <h2><a href="<?php the_permalink() ?>" rel="bookmark" title="Permanent Link to <?php the_title_attribute(); ?>"><?php the_title(); ?></a></h2>
    <!-- Display the date (November 16th, 2009 format) and a link to other posts by this posts author. -->
    <small><?php the_time('F jS, Y') ?> by <?php the_author_posts_link() ?></small>
    <div class="entry">
    <?php the_content(); ?>
    </div>
    <p class="postmetadata">Posted in <?php the_category(', '); ?></p>
    </div> <!-- closes the first div box -->
    <?php endwhile; else: ?>
    <p>Sorry, no posts matched your criteria.</p>
    <?php endif; ?>

    PS. Second issue relates to child themes messing up the top navigation, but we're still testing to get it working.

  2. alex27
    Member
    Theme Author

    Posted 1 year ago #

    Where did you put this code? Did you replace original query_posts from index.php? Because this is where reviews and videos are included into the loop.

  3. gahoo
    Member
    Posted 1 year ago #

    Thanks Alex. That was enough of a push in the right direction.

    We apparently had the category filter in both loop.php (maybe not even called?) and gamepress/index.php (and I guess didn't realize which was doing the actual filtering). Removing the filter it from index.php did the trick. So now maybe we lost our category filter, but at least we can use the custom posts in the meantime.

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic