WordPress.org

Ready to get started?Download WordPress

Forums

Google Language Translator
[resolved] return with no translation to original language (10 posts)

  1. gstrambi
    Member
    Posted 1 year ago #

    Hi everybody, i've this problem:

    * my site has italian as original language
    * i've selected specifc language to display to visitors
    * in order to return to default language i've selected also italian in displayed languages
    * the problem is that in case i choose a language different to the deault and than select gain the default language to return to original one... i've not the original text but a translation of it, like my original text beeing translated to english and than re-translated to italian

    for example, in my mai menu, i've HOME button (in italian we use HOME for Home page like in english...)

    if i choose a different language the term HOME went translated

    if now i choose italian language my button text became DOMESTICO that in italian is like DOMESTIC!

    Is there the possibility to refresh to original version texts in case visitors change back to the language choosen like "original language of your website" in admin?

    sorry for my bad english, i hope you understand what i mean...

    http://wordpress.org/extend/plugins/google-language-translator/

  2. gstrambi
    Member
    Posted 1 year ago #

    i forgot.... you can see and test my website at http://www.leduequerce.toscana.it/
    thanks

  3. PREZZIE
    Member
    Posted 1 year ago #

    Hi, I currently have the same issue. I installed the plugin on a site that runs in Dutch as the default language, when selected english, how can I return back to dutch?

    thx

  4. Rob Myrick
    Member
    Plugin Author

    Posted 1 year ago #

    Hi gstrambi, there's a lot of information there, but this is a good question.

    You mentioned having the original language "Italian" shown as one of the menu languages. I do not currently see "Italian" listed in the drop-down at all from my end, so I cannot currently test your site. Did you remove the "Italian" language?

    Let's start there. I will further try to help you once we go through some initial steps. And I can also help you prevent specific pieces from translating if you need. I'll look forward to your reply.

    Thanks, Rob

  5. Rob Myrick
    Member
    Plugin Author

    Posted 1 year ago #

    Hi PREZZIE, I'm assuming you have "Specific Languages" selected as your option. Do you currently have "Dutch" checked so that it shows in the drop-down. Hopefully it does show up if you have placed a checkmark in the box, then I would hope that you can get back to the original language. Also, would you mind sharing a link to your site and I can try testing?

    Thanks so much!

  6. Rob Myrick
    Member
    Plugin Author

    Posted 1 year ago #

    HI gstrambi, I also noticed that in your website's header, there are two instances of Google Language Translator being loaded.....interesting. You may want to remove one of those, as Google doesn't seem to allow more than one instance of the Translate tool on your website. Talk to you soon!

  7. gstrambi
    Member
    Posted 1 year ago #

    Hi Rob, thanks for your reply!

    Now i've only one istance, sorry, but that is not the cause of my problem.

    I've re-activated italian language, it was de-activated beacause the problem i've explained, sorry!

    As you can see if you start in italian, main language, than change language and than return to italian, original text are changed in several cases. I've noted that terms that are different in italian language on start-up and after a language change, are the terms that in italian are used in english in any case...like HOME, or, in footer, creted by...

    when the site starts in original language you can see HOME button in menu, than if you change language and come back to italian, you find DOMESTICO insted of HOME and in footer you start with created by and after you find creato da...

    Thanks, bye

  8. Rob Myrick
    Member
    Plugin Author

    Posted 1 year ago #

    Hi gstrambi, I'm thinking this issue is actually related to the way Google translates web pages - it's one of the imperfections of their translation tool, because the translation itself is something that I cannot control.

    However, I can still help you with this. We can prevent translation on specific menu items if you want. Let me know if you like this idea. By default, WordPress allows you to avoid translation by adding class="notranslate" on any HTML tag. So we need to target those 2 specific menu items and add the notranslate class to it.

    You could possibly do this in Appearance > Menus.

    Up at top right of that screen there are "Screen Options". Once you click that, you can check the box, "CSS Classes" that appears there. This will allow you to add CSS classes to individual menu items. So add notranslate to the "CSS Class" field for each menu item that you do not want translated, and do it for both the header and footer menu items you mentioned. Save changes, and that should do it!

    The only drawback to doing it this way is that those specific menu items will not be translated. If you can deal with that I think you should be happy with the results.

    Let me know if that helps!

  9. gstrambi
    Member
    Posted 1 year ago #

    Hi again, in my case your solution is perfect, i've only 2/3 items that cause problems. Thanks!

    But in future revisions i think the better solution could be to always include orginal language in drop down languages menu, exclude it in selectable specific language or "all languagea" setting and linking to that language a complete refresh of the site to restore language as at first access to site.

    If you try to change languages and than return to original one as i said in my first post, having the wrong original version, it will be sufficient to refresh the page to return to real original texts.

    I hope to have correctly explained my concept, sorry but my english is not very good! :)

    In any case thanks a lot, i'll try your solution as soon as possible reporting you.

    Bye

  10. Rob Myrick
    Member
    Plugin Author

    Posted 1 year ago #

    Ok, I now fully understand your situation - you are saying that if I offer the Default Language (in your case, "Italian") in the drop-down on the website, you would rather see it refresh the page back to your original intended text, instead of translate that menu item. Right? Because in your case, Google translated your text (i.e. Home) into it's translated meaning, (Domestico), right?

    I will see if there is a way I can incorporate this change in the future. But I'm thinking that by using "Home", (which is actually in English), the software will likely never be able to decipher your preferences on it's own. I guess that's one of the difficult aspects of machine translation :)

    But you are absolutely right - there is major value in just translating the text back to your original website. I will do some testing to make sure this is not a glitch in the plugin.

    Thanks so much for your feedback, gstrambi.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.