WordPress.org

Ready to get started?Download WordPress

Forums

Pronamic iDEAL
[resolved] Return URL? (13 posts)

  1. trollytownstudio
    Member
    Posted 1 year ago #

    Hi Pronamic,

    I'm using Gravity Forms, Sisow as a payment provider and choose iDeal advanced in your plugin.

    Everything is working fine except that after a succesfull payment the customer gets redirected to our home-page instead of the "betaling voltooid" page. In the plugin you can choose "page-generator" and I generated these pages. In the iDeal section of Gravity Forms I checked the "status koppelingen" and connected them to the required pages. I also put in the "success-URL" in the Sisow payment interface although Sisow says this is covered by the plugin ..

    Can you tell me what I'm missing?
    Thanks in advance.

    http://wordpress.org/extend/plugins/pronamic-ideal/

  2. Remco Tolsma
    Member
    Plugin Author

    Posted 1 year ago #

    I can't reproduce this problem with the following configuration:

    • WordPress 3.5.1
    • Gravity Forms 1.6.12
    • Pronamic iDEAL 1.2.4

    I used the Sisow - Advanced variant in test mode. If i choose for the "Success" status i'm redirected to the "iDEAL payment completed" page. If i choose for "Expired" i'm redirected to the "iDEAL payment expired" page.

  3. pewoldt
    Member
    Posted 1 year ago #

    I am experiencing the same issue. My configuration:

    • WordPress 3.5.1
    • Gravity Forms 1.6.12
    • Pronamic iDEAL 1.2.4
    • Sisow – Advanced

    It was working fine in test mode. The success, cancelled, failed and Expired statuses were redirecting to the corresponding pages correctly. Since I switched to live mode (and changed the URL from uod2013.utrechtseondernemersdag.nl to http://www.utrechtseondernemersdag.nl) it is redirecting to the homepage in all cases.

  4. Remco Tolsma
    Member
    Plugin Author

    Posted 1 year ago #

    What is the status of the payment on the "iDEAL » Payments" page?

  5. pewoldt
    Member
    Posted 1 year ago #

    The status is "Onbekend". In the payments overview the transaction ID is not populated for these transactions.

    I did some tests (iDEAL > Configurations > Sisow - iDEAL Advanced > Tests) and for those tests the status is correct (Succes, Verlopen, ...) and the transaction ID is populated but after finishing the test transactions it redirected to the homepage again.

  6. Remco Tolsma
    Member
    Plugin Author

    Posted 1 year ago #

    I also can't reproduce the problem in 'live' mode.

    Since I switched to live mode (and changed the URL from uod2013.utrechtseondernemersdag.nl to http://www.utrechtseondernemersdag.nl) it is redirecting to the homepage in all cases.

    What are the values of the 'Site URL' and 'Home URL'? You can find these on the "WordPress admin » iDEAL » Settings" pagina.

  7. pewoldt
    Member
    Posted 1 year ago #

  8. pewoldt
    Member
    Posted 1 year ago #

  9. Remco Tolsma
    Member
    Plugin Author

    Posted 1 year ago #

    We just launched a new version (1.2.5) of the Pronamic iDEAL plugin:
    http://downloads.wordpress.org/plugin/pronamic-ideal.1.2.5.zip

    We did some small adjustment, i'm not sure it will solve the issue, but it's worth trying.

  10. pewoldt
    Member
    Posted 1 year ago #

    Unfortunately the new version of the plugin did not solve the issue.

    Any other ideas? Can I maybe turn on debugging or something to get more info to see what is going wrong?

  11. Remco Tolsma
    Member
    Plugin Author

    Posted 1 year ago #

    Can we get temporary access to your WordPress admin area? You can e-mail it to info@pronamic.nl.

  12. dizda
    Member
    Posted 1 year ago #

    I am having the exact same problem. It keeps redirecting to the homepage in both test and live mode.

    • WordPress 3.5.1
    • Gravity Forms 1.6.12
    • Pronamic iDEAL 1.2.5
    • Sisow – Basic

    I tried turning off other plugins and turning off SSL(backend). Still no succes.

    Other ideas?

  13. Remco Tolsma
    Member
    Plugin Author

    Posted 1 year ago #

    We fixed the issue in the WordPress website of @pewoldt. The problem was a missing "Issuer Drop Down" (Bankenuitschuifkeuzelijst) in the Gravity Forms form.

    @trollytownstudio Could you check if you use the "Sisow - iDEAL Avanced" variant and have an "Issuer Drop Down" in your form?

    @dizda You should switch to "Sisow - iDEAL Advanced" and add an "Issuer Drop Down" to your form.

    I will mark this topic is 'resolved', if you still have a problem please start a new topic.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.