WordPress.org

Ready to get started?Download WordPress

Forums

Retreive First Image From Post (7 posts)

  1. dannbkk
    Member
    Posted 4 years ago #

    Ok I am having an issue:

    Seems as though the thumbnail gets added properly if I add an image through posting and when it stores itself locally: wp-content/uploads/2009/09/blue-2009-8b-1_12506756341.jpg .

    But If I put a image url location from another site the thumbnail doesn't appear in the initial post, so it doen't retrieve the first image from the post at all? Any ideas please?

  2. Dave Redfern
    Member
    Posted 4 years ago #

    Make sure the image url for the other site has http:// in front of it else it will still think the image is local.

    don't know if that is the problem?

  3. dannbkk
    Member
    Posted 4 years ago #

    The image is located on a subdomain of my site for example:

    <img src="http://gallery.mysite.com/images/28933308271481885245_thumb.jpg" border="0" alt="28933308271481885245.jpg" />

    Any thoughts? The only other thread I could find that could help me is possibly this one:
    http://wordpress.org/support/topic/246893

  4. s_ha_dum
    Member
    Posted 4 years ago #

    How are you inputting the image URL? And what are you using to call the thumbnail?

  5. dannbkk
    Member
    Posted 4 years ago #

    There is no option to call the thumbnail wordpress automatically posts the first image in the initial blog, but I am posting the urls in the post rather then clicking image and getting image that way, do you think this is the issue? If so what is the best way to settle this. If I try and add an image from url source it comes up with x?

  6. s_ha_dum
    Member
    Posted 4 years ago #

    but I am posting the urls in the post rather then clicking image and getting image that way, do you think this is the issue?

    I'm thinking it might be an issue. I don't deal with images a lot but I believe that the 'thumbnail' effect is generated by the use of attachment metadata which is stored in the wp_postmeta table. An actual thumbnail image is never generated. The image is just resized using width and height attributes in the generated html. If you don't upload, you don't create that metadata and so the thumbnail trickery can't really work.

  7. dannbkk
    Member
    Posted 4 years ago #

    Could someone please have a look at this for me, please pm me for my login details.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.