WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Resumé Submissions & Job Postings] showing just one resume (16 posts)

  1. peterrodger
    Member
    Posted 2 years ago #

    I'm using the plugin 'Resumé Submissions & Job Postings' which is just great for this small charity. I have a small problem in that when I call the shortcode to display a list of submitted resumes [resumeDisplay] the page displays only the most recently submitted resume. I rather thought that all the current submissions should be displayed. Have I missed something?

  2. kandrews
    Member
    Posted 2 years ago #

    You should be able to add limit=100 (or whatever amount) into that shortcode to set a limit on the amount of posts displayed.

  3. peterrodger
    Member
    Posted 2 years ago #

    Thanks for this. I've changed the shortcode to read [resumeDisplay limit=100] but the page still displays only the single, very latest of the 3 submissions posted so far. Each new resume that I add (this is a development site at present) is the only one that is displayed. All the submitted PDF files are in the correct place but only the latest one is displayed on the page.
    Interestingly, if I change the submission times in the database the submission with the most recent date & time is displayed. Even if I vary the submission times between 2 of them, by only one second, the most recent is the only one to be displayed.

  4. kandrews
    Member
    Posted 2 years ago #

    Ok, I do see the error.

    The function I have called to get the pdf is giving an error, which is stopping the for statement from displaying the rest of the entries.

    I will get this fixed in the next update that should be released on 5/15.

  5. peterrodger
    Member
    Posted 2 years ago #

    Ok - Many thanks for this Keith. I'll look out for the release on Sunday.

  6. kandrews
    Member
    Posted 2 years ago #

    This error is now fixed in the update to 2.1.7

    Thanks.

  7. peterrodger
    Member
    Posted 2 years ago #

    Hi Keith - many thanks for the updated version which I have downloaded and installed. Unfortunately, rather than solve the problem - it has made it worse. The page using [resumeDisplay] no longer displays any resume links. There are just none!

  8. kandrews
    Member
    Posted 2 years ago #

    I guess uploading the new file that fixes this would probably help...

    Delete and re-download it.
    It should work then.

    Sorry about that.

  9. peterrodger
    Member
    Posted 2 years ago #

    Keith - is it just one file? If so which one and where will I find it? The update link in the plugins folder is no longer there because I used it to update a few minutes ago. I don't really want to delete the entire plug-in since there are some jobs already entered.

  10. kandrews
    Member
    Posted 2 years ago #

    It is one file called pdf-functions.php in the includes folder.

  11. peterrodger
    Member
    Posted 2 years ago #

    Brilliant! Thank you very much Keith. I'm really pleased with this plug-in. Any chance that the "no line breaks" problem in TinyMCE might be solved any time soon? And are there any plans for the outputted PDF files (of the resumes) to follow the formatting of the source pages? This also seems to be a "line break" issue.
    Peter

  12. kandrews
    Member
    Posted 2 years ago #

    Thank you for using it.

    I have been looking at the TinyMCE problem for a bit now.
    So far no luck as I seem to be doing everything correctly (I hope),
    yet it still takes the p tags away.

    A work around for this would be to download the plugin "Advanced TinyMCE".
    This is on our dev site and works perfectly.

  13. peterrodger
    Member
    Posted 2 years ago #

    Keith - can you offer me any clues about implementing Advanced TinyMCE in your plug-in. I've installed it and it now appears as the default for 'pages and posts' (in the core) but stubbornly will just not appear in Resumes and Job Posts. Actually, I couldn't find "Advanced TinyMCE" but did find "TinyMCE Advanced" which I imagine is the same thing.

  14. kandrews
    Member
    Posted 2 years ago #

    Yes, under the Settings panel you should see "TinyMCE Advanced".

    In there find in the advanced box at the bottom, "Stop removing the p and br tags when saving".

    Make sure this is checked.

    This plugin basically mods the existing TinyMCE to allow for more options when using it.

  15. peterrodger
    Member
    Posted 2 years ago #

    Thanks I can see that now. BUT - and this may be interesting for you - in the few minutes before your last message I looked through your 'functions.php' file and found the 'wpautop' => true, which I changed to 'wpautop' => false, - and guess what? Yup, when I created a new job posting the <p> tags were retained. When I have a litle time I'll do a fresh install of this plug-in on another site and see what happens. In the meantime, many thanks for your patience and help.
    Peter

  16. kandrews
    Member
    Posted 2 years ago #

    Yeah, just tried it on my end and it does work now...

    The only thing I didn't try ha.. and set to true is suppose to mean that is does put them...

    Weird.

    But I appreciate you letting me know!

Topic Closed

This topic has been closed to new replies.

About this Topic