WordPress.org

Ready to get started?Download WordPress

Forums

Proper Widgets
Restricting the size of the comment field (2 posts)

  1. samolmsteadlaw
    Member
    Posted 1 year ago #

    Hi there! I'm new to customizing widgets and I have had no luck using other contact form widgets. Thank you for developing something that is functional and easy to use, even for a novice!

    I do have a few quick questions, though. How could one restrict or limit the size of the comment field (where the person filling out the form would enter their comment, live on the site)?

    I'm trying to use your comment form as a sidebar widget - as no other sidebar widget I could find would work. I've tested the functionality of the form as a widget and it worked great - but, you have to resize the comment box for it to all fit in the sidebar. Any help would be greatly appreciated.

    Secondly, my "Thank you" message is displaying, as I'd hoped after a submission - however, the text is quite large. How can I edit that? Thanks!!

    http://www.samolmsteadlaw.com
    (Using the Craft Theme by Theme Trust)

    http://wordpress.org/extend/plugins/proper-widgets/

  2. properwp
    Member
    Plugin Contributor

    Posted 1 year ago #

    samolmsteadlaw ... thanks so much for the compliment! This plugin came about from coding contact forms for a number of different people in different situations and I figured that information could help others.

    Answering in order:

    1. There is nothing in place to limit the length of the comment field, at this point. Are you worried about comments being too long or about the size of the box? You'd have to add some CSS in there. We're going to add a few style options on the settings page at some point. For now, you'd need to add that CSS in your theme files or, if you have a settings field for it, add it there. When I look at your site, it seems like it's behaving. Do you have an example of where it's not appearing correctly? I can send over the CSS to use.
    2. I believe that "thank you" text is added to a header, making it look large. You can, instead, create a "thank you" page in WordPress, with all the correct styles and content, then use the "Thank You" URL setting to send it to that page.

    Hope that helps!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic