WordPress.org

Ready to get started?Download WordPress

Forums

BackWPup Free - WordPress Backup Plugin
[resolved] "Restart on every main step" not accept to be disabled! (8 posts)

  1. Marcelo Pedra
    Member
    Posted 1 year ago #

    Hi! I continue testing the new version of this plugin and found that in some installations of WP, the option "Restart on every main step" refuse to be disabled. No matter how many times I disable it and save changes, it won't get through.
    The weird thing is that in 2 WP sites in the same server, being one of them a multisite, it has been disabled at the first attempt. In the other 5 sites it doesn't work.
    The plugins in all those websites are almost the same. In fact, the multisite have almost the double of plugins than the others.

    Any idea?
    (I wonder if I can set the option to 0 from phpmyadmin or if doind this may I break some plugin config)

    Thank you

    http://wordpress.org/extend/plugins/backwpup/

  2. Marcelo Pedra
    Member
    Posted 1 year ago #

    UPDATE:
    I opened phpmyadmin and see that in the websites where option "Restart on every main step" may be deactivated, the wp_options table has backwpup_cfg_jobsteprestart=''
    whereas the websites that are refusing to untick this option DONT HAVE that value present.

    Looks like some weird condition occuring in the installation of the plugin. I use to manage my WP sites with InfiniteWP remote management plugin, and those sites where I get this option to work ok were those where I personally upgraded the plugin (the multisite and one individual website).
    In the other sites, I get this to working state using "Reset all settings to default" in order to make the plugin rewrite all the options in the wp_options table.

    So, check the installation procedure, since there are glitches when it create the options in the db.

  3. Marcelo Pedra
    Member
    Posted 1 year ago #

    BTW, by doing this option reset and reconfigure the whole plugin, the websites where the backup was working ok, showed that the elapsed time to complete a backup job was reduced from 380 seconds to just 11!

  4. Daniel Hüsken
    Member
    Plugin Author

    Posted 1 year ago #

    You can disabel the option if WP_ALTERNATE_CRON active than it will not usesd because it can't work.

    The option is enabled by defauld, because there are to many hosters that not work without the option.

  5. Marcelo Pedra
    Member
    Posted 1 year ago #

    Nope, I don't use WP_ALTERNATE_CRON anymore, because your previous version was colliding with that option and then I double checked that my sites not use this option anymore.

    But please, take a minute and read the last paragraph of my second reply in this thread. The glitch is in how the plugin record its configuration data in wp_options: it's forgetting this variable, backwpup_cfg_jobsteprestart.

  6. slackerofthemind
    Member
    Posted 1 year ago #

    I am also experiencing all of the above issues:

    (1) Plugin stalls upon Run with:

    ERROR: ZipArchive returns status: (ER_DELETED) Entry has been deleted

    (2) Cannot uncheck "Restart the job on every main step on a working job "

    Plugin failure.

  7. mrkingid
    Member
    Posted 1 year ago #

    I still get the checkmark returning after a full delete and fresh install of backwpup

    Restart the job on every main step on a working job

  8. Marcelo Pedra
    Member
    Posted 1 year ago #

    Did you try resetting the options in the configuration page?
    It solved the issue to me.

    Anyway, this is an actual bug that Daniel has to fix.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic