WordPress.org

Ready to get started?Download WordPress

Forums

Edge Suite
[resolved] Resource interpreted as image... (4 posts)

  1. pjburnhill
    Member
    Posted 1 year ago #

    Hi again Tim,

    I had some issues with uploading the .OAM files - they kept uploading to http://www.pjpalomaki.com//var/sites/p/pjpalomaki.com/public_html/wp-content/uploads/edge_suite/ but I noticed in another post to check Settings -> Media and lo-and-behold it was set to /var/sites/p/pjpalomaki.com/public_html/wp-content/uploads/ in stead of /wp-content/uploads/. So I changed this and reinstalled Edge Suite and it now uploads the content to the correct place.

    There is one thing which hasn't happened before until now though and is these messages in console:

    Resource interpreted as Image but transferred with MIME type application/javascript: "http://www.pjpalomaki.com/wp-content/uploads/edge_suite/edge_includes/jquery-1.7.1.min.js". Hello-1_edgePreload.js:2
    Resource interpreted as Image but transferred with MIME type application/javascript: "http://www.pjpalomaki.com/wp-content/uploads/edge_suite/edge_includes/jquery.easing.1.3.js". Hello-1_edgePreload.js:2
    Resource interpreted as Image but transferred with MIME type application/javascript: "http://www.pjpalomaki.com/wp-content/uploads/edge_suite/edge_includes/edge.1.0.0.min.js". Hello-1_edgePreload.js:2
    Resource interpreted as Image but transferred with MIME type application/javascript: "http://www.pjpalomaki.com/wp-content/uploads/edge_suite/project/hello-1_1/Hello-1_edge.js". Hello-1_edgePreload.js:2
    Resource interpreted as Image but transferred with MIME type application/javascript: "http://www.pjpalomaki.com/wp-content/uploads/edge_suite/project/hello-1_1/Hello-1_edgeActions.js". Hello-1_edgePreload.js:2

    Any idea what's going on here? I checked the /wp-content/uploads/ folder in FTP and it shows the edge_suite folder as restricted and the permissions are 755. I can't actually get inside that folder. Is this the usual practice for Edge Suite?

    My site is under maintenance mode at the moment, but I can give you guest access if you'd rather have a look yourself.

    Thanks Tim.

    http://wordpress.org/extend/plugins/edge-suite/

  2. ti2m
    Member
    Plugin Author

    Posted 1 year ago #

    I do get the "Resource interpreted as Image but transferred with MIME type application/javascript", but that isn't because of the plugin as far as I can tell. I couldn't really figure out where these notices come from... I'll have to check up in the Adobe forums.

    The folder permissions are based on your hoster setup and are (if you ask me) a bit strange in wordpress. If the FTP user and the www-data user are not in the same group you might run into issues. Do you get the red notice box on the "manage" page? That's why I added the extra setting to kill all the folders when you deactivate the plugin so you can at least get rid of that stuff.

    I'm planning a complete rewrite of the plugin, which will also handle the files differently, therefore I won't work on the file issue (as there is not that much to work on anyway).

  3. pjburnhill
    Member
    Posted 1 year ago #

    Hmm interesting, I didn't used to get those issues when the content was installed in the wrong folder. Never mind, it doesn't seem to affect the usage as far as I can tell.

    I do not get the red notice box in the manage page and the plugin functions as it should. Just found this strange. I'll use the extra setting if I need to remove the whole plugin and content.

    Thanks for your hard work Tim, it's a good plugin and potentially very powerful and useful the more EA stuff gets around.

    Thanks,
    PJ

  4. pjburnhill
    Member
    Posted 1 year ago #

    Oops, didn't mean to set this as resolved, since it hasn't been properly resolved... not sure if there's a way to un-resolve?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic