WordPress.org

Ready to get started?Download WordPress

Forums

Buddy-bbPress Support Topic
[resolved] [resolved] Adding style to [support] on group forums (5 posts)

  1. danbp
    Member
    Posted 1 year ago #

    If you want to add css to the [support] on BP 1.6.x group forums it's impossible to do correctly due to a permalink title in BP's forum-loop
    The css tip given by imath in the plugin readme concern only the SW forum using the complete bbPress plugin.

    This is now fixed in the trunk and can be used on stable BP 1.6.x
    Ticket here: http://buddypress.trac.wordpress.org/ticket/4770
    Changeset: http://buddypress.trac.wordpress.org/changeset/6725

    I explained the usability here:
    http://wordpress.org/support/topic/some-glitches-with-infinitybalance-theme?replies=3

    http://wordpress.org/extend/plugins/buddy-bbpress-support-topic/

  2. imath
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks, then i'll add filters on next release so it will be easier to add the html you want..

    I read the ticket, and it's planed to be available for 1.7 release..

  3. imath
    Member
    Plugin Author

    Posted 1 year ago #

    Hey Dan ;)

    1.0.1 now includes a filter, so you can play with it in your functions.php of your active theme to achieve your goal without modifying the plugin :

    add_filter('bp_bbp_st_print_support_type', 'dan_style_support_topic', 10, 2);
    
    function dan_style_support_topic( $topic_status, $support_status ) {
    
    	if( $support_status == 2 ) {
    		return '<span style="color:green">' . $topic_status .'</span>';
    	} else if( $support_status == 1 ) {
    		return '<span style="color:red">' . $topic_status .'</span>';
    	} else {
    		return $topic_status;
    	}
    
    }

    merci pour ton aide, buddy ;)

  4. abmlearningandquality
    Member
    Posted 1 year ago #

    Hey imath,

    I love your plugin, and I was testing the filter you provided above with my theme (since the one in style.css file didn't work for me).

    It changes the color of my support status, but it adds a duplicate of the topic title with a -Permalink" behind it. Here is a snapshot: http://i.imgur.com/EO4gJeR.png

    Any thoughts on how I can fix this?

    I am using the latest Buddypress/ bbpress/ WordPress versions with a BuddyBoss theme.

    Thanks in advance!! You're plugins are the best! :)

  5. imath
    Member
    Plugin Author

    Posted 1 year ago #

    It's a bit early for you to use this if you haven't patch your BuddyPress as Dan explains above.

    This is now fixed in the trunk
    Ticket here: http://buddypress.trac.wordpress.org/ticket/4770
    Changeset: http://buddypress.trac.wordpress.org/changeset/6725

    If you use a different theme than BP Default, i suggest you to search the /forums/forums-loop.php, then search for something like :
    <a class="topic-title" href="<?php bp_the_topic_permalink(); ?>" title="<?php bp_the_topic_title(); ?> - <?php _e( 'Permalink', 'buddypress' ); ?>">

    Then you'll need to delete in the title attribute of this link <?php bp_the_topic_title(); ?>

    Hope it helps you to customized your style.
    And thanks a lot for your interest in my plugins :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags