WordPress.org

Ready to get started?Download WordPress

Forums

Resistration Email With Bluehost (13 posts)

  1. shiner_man
    Member
    Posted 5 years ago #

    I have the following email address entered in the settings page in WordPress:

    webmaster@drexelrowingalumni.org

    However, when a person registers for the site they get an email notification from:

    erbcontr@box260.bluehost.com

    I contacted Bluehost support and they sent me back the following:

    WordPress may be trying to send from the address but not recognizing that it exists on the server or perhaps it has been mistyped in wordpress. Be sure that you have entered in the correct information inside WordPress. If you are still experiencing this problem I'd recommend contacting WordPress support for further troubleshooting as this is outside my realm of support.

    Any ideas what the problem is here?

  2. iridiax
    Member
    Posted 5 years ago #

    Have you tested this email (sent and received emails from it) outside of WordPress?

  3. shiner_man
    Member
    Posted 5 years ago #

    Yes, it works both ways.

  4. BernardBorealis
    Member
    Posted 5 years ago #

    Try creating an email account called wordpress@yourdomain.com and setting your email address on wordpress as wordpress@yourdomain.com. WordPress has some strange issues where the mail won't work properly sometimes without it. Also, you may want to double-check that your admin email address is set properly in the database.

    This is the way Bluehost requires their headers to be:
    Examples of headers that should work would be:
    From: user@domain.com
    From: <user@domain.com>
    From: "name" <user@domain.com>

    Examples of headers that will NOT work:
    From: "user@domain.com"
    From: user @ domain.com

    Alternative for PHP Users:
    - You can also modify which account should be used when sending out using the mail() function. Inside the local php.ini file, you will find a line of code that looks something like this (around line 601):

    sendmail_from = mail@yourdomain.com

    Be sure to uncomment this by deleting the ';' before the directive. Also, the account you use must be a valid created account.

    There is also a plugin called wp-mail-smtp. You can install that and set it to send mail using smtp, then send mail from your email address. (Make sure that the email address set is actually created in your cPanel.) Check YES for the option to use smtp authentication. That should work, too.

  5. shiner_man
    Member
    Posted 5 years ago #

    Try creating an email account called wordpress@yourdomain.com and setting your email address on wordpress as wordpress@yourdomain.com.

    This did the trick.

    Thanks a lot!

  6. thomasw98
    Member
    Posted 5 years ago #

    Try creating an email account called wordpress@yourdomain.com and setting your email address on wordpress as wordpress@yourdomain.com.

    This did not work for me. Same problem as before.

  7. thomasw98
    Member
    Posted 5 years ago #

    wp-mail-smtp is a partial solution. It changes the "sent from" address that is visible to email recipients. But if the recipient checks in the message headers, they will still see lots of bluehost references that I do not want them to see.

  8. modifiedcontent
    Member
    Posted 4 years ago #

    Is there a good solid solution to this? I've seen several threads about this on different forums and they all end with the same partial solutions.

  9. bh_WP_fan
    Member
    Posted 4 years ago #

    There are several ways of fixing/working around this. Some are mentioned in some posts and others in different posts. Depending on the setup, plugin, or whatever may be involved, it seems people have different results or preferences.
    I will list a few of the common ways that have worked for me:

    First is to change the way WordPress generates the headers:

    1) You can modify wp-includes/class-phpmailer.php and change the following lines(around line875 if using WP 2.7):

    $result .= $this->AddrAppend('From', $from);

    to

    $result .= $this->AddrAppend('From', $from);
    $result .= $this->AddrAppend('Envelope-from', $from);

    That should fix the problem, though it won't work for any plugins that don't use class-phpmailer.php

    2) WordPress uses wordpress@domain.com as the default email address. You can either create and use this address, or you can download the following plugin which allows you to alternate the wordpress@ address to anything you want (@yourdomain.com)
    http://wordpress.org/extend/plugins/wp-from-email/

    3) You can install a plugin like(but not limited to): http://wordpress.org/extend/plugins/wp-mail-smtp/ and in the plug-in options tab set the options to:
    send mail using SMTP,
    send the mail using your new email address,
    fill in the SMTP host, username and password that your host gave you when you set up the new email address,
    YES, use smtp authentication. (Yes, I'm aware this method doesn't actually change the headers, but most people don't bother with them anyway)

    These are some common ways to fix the WordPress email woes. Hope it helps

  10. modifiedcontent
    Member
    Posted 4 years ago #

    Thanks!

    Suggestion #1 had zero effect.

    The wp-from-email plugin sort of fixed the problem, but seems to conflict with my MM Forms contact form. Emails from the contact form now all have my own email as sender, instead of the email address the user enters.

    Sending email using SMTP seems overkill. I think I've tried that in the past and that it caused all kinds of other problems.

    Any other ideas?

    :-(

    EDIT: If Bluehost is very strict in their email header requirements:

    This is the way Bluehost requires their headers to be:
    Examples of headers that should work would be:
    From: user@domain.com
    From: <user@domain.com>
    From: "name" <user@domain.com>

    Does WordPress adhere to those requirements? Where in WP is the code that forms these headers?

  11. bh_WP_fan
    Member
    Posted 4 years ago #

    I haven't played around with the scripts enough to be certain where/what all needs to be changed, however, I'd guess it would be in relation either to wp-includes/pluggable.php on or around lines 349-354, and/or in wp-includes/class-phpmailer.php around lines 71-82.

    There is also this trac report on the cause of the issue: http://core.trac.wordpress.org/ticket/5007

  12. modifiedcontent
    Member
    Posted 4 years ago #

    bh_WP_fan, are you sure this is the same issue. The trac report talks about email notifications not arriving at all, "landing in dead.letter".

    My emails arrive fine, with or without the plugins. I just have trouble getting the right From: line to show on the email.

  13. vinayy
    Member
    Posted 4 years ago #

    I am using a combination of the following plugins:

    HGK SMTP (http://wordpress.org/extend/plugins/hgk-smtp/)
    Mail From (http://wordpress.org/extend/plugins/mail-from/)

    "Mail From" is the one to set the "reply to" email to replace the default wordpress@domain.com to any_email@domain.com.

    Using for WordPress 2.8.4

    Namaste

Topic Closed

This topic has been closed to new replies.

About this Topic