WordPress.org

Ready to get started?Download WordPress

Forums

Resetting everything to default? (7 posts)

  1. dafunks
    Member
    Posted 6 years ago #

    Hi, I have a SQL DB which I think is 2.2 or 2.1 and I now wish to get the posts and import them to my new blog which is 2.3.1. I have setup a new wordpress and set it up to get the sql db from my old one and I thought I could import the files this way but as the settings are all setup for the old theme i used and all the plug-ins I keep getting errors.

    Is there a easy to just get all the basic settings so I can do a export and then my problem is fixed.

    I would normally just switch the db but I have been running my new blog for a few months now and just wish to import the posts of my old blog to stop all my Google search errors i keep getting.

  2. moshu
    Member
    Posted 6 years ago #

    You cannot do that in that way. You can import/export DBs only in between same versions.
    So, you either upgrade your old blog and do the backup/restore after that, or you install the same version at the new location and do the upgrade after the import.

  3. dafunks
    Member
    Posted 6 years ago #

    Ok. How would i upgrade the database? I used the upgrade.php but it still is not working.

    I think its because I had plugins installed and now it is searching for them but as tehy are not there i get errors.

  4. Roy
    Member
    Posted 6 years ago #

    Download the new version of WP, upload the whole thing and then use install.php. All this of course on your old installation. After this you make a new export and then importing in the new installation (also 2.3.1 of course) should be no problem.

  5. moshu
    Member
    Posted 6 years ago #

    Download the new version of WP, upload the whole thing and then use install.php. All this of course on your old installation.

    That's completely wrong!
    Do that ONLY if you want all your blog wiped out!!!
    Gangleri, try that on your won blog... just don't complain if you wake up with an empty blog.

    For an upgrade you run the upgrade.php, NEVER the install.php.

  6. dafunks
    Member
    Posted 6 years ago #

    I used the upgrade.php but it never worked for some reason.

    i get this error:

    Warning: Cannot modify header information - headers already sent by (output started at /home/website/public_html/test123/wp-config.php:47) in /home/website/public_html/test123/wp-includes/pluggable.php on line 391

  7. moshu
    Member
    Posted 6 years ago #

    public_html/test123/wp-config.php:47)

    If you have searched the Codex you could figure out that you have an empty/blank line in your config file on line #47.

Topic Closed

This topic has been closed to new replies.

About this Topic