WordPress.org

Ready to get started?Download WordPress

Forums

EWWW Image Optimizer
[resolved] Requires exec(). (6 posts)

  1. investacube
    Member
    Posted 10 months ago #

    Hi, I am getting this message - EWWW Image Optimizer requires exec(). Your system administrator has disabled this function. I am using krystal.co.uk hosting. Is it something I can resolve? Thanks

    http://wordpress.org/plugins/ewww-image-optimizer/

  2. nosilver4u
    Member
    Plugin Author

    Posted 10 months ago #

    You'll have to ask Krystal Hosting if they allow exec() to be enabled, and how to do that, as it varies by webhost. If they don't allow exec(), you have two options:

    1. find a webhost that allows exec(): http://wordpress.org/plugins/ewww-image-optimizer/other_notes/

    2. sign-up for the EWWW IO Cloud service (there are still free keys available during the beta period): http://www.exactlywww.com/cloud/

    Please post back when you hear from Krystal Hosting, so that others know their position on the exec() function.

  3. ladybugjewellery.com
    Member
    Posted 8 months ago #

    Hi NoSilver4u,

    Sorry to bother you again with this topic, I'm sure you've been answering it for a while now but I'm still not sure how I shall progress to enable the function exec().
    The message I get is:
    Your system administrator has disabled this function.
    However, I'm the system admin.

    I don't know how to code, and I'm using One.com as a hosting provider.

    Thanks in advance.

  4. nosilver4u
    Member
    Plugin Author

    Posted 8 months ago #

    The best advice I can give you is exactly what I told the last user:
    Ask your webhost if they even allow exec() at all. If they do, ask them how to enable it.
    If they don't allow it, you have the same two options as above.

  5. digbymaass
    Member
    Posted 3 months ago #

    This isn't resolved. I'm the admin for the site and this plugin doesn't work because I apparently have disabled this function. I don't expect to download a plugin that doesn't work because of some exotic server thing that I can't possibly hope to solve.

    Goodbye plugin.

  6. Xonova Hosting
    Member
    Posted 1 month ago #

    If this is still relevant to anyone.
    It doesn't matter whether or not you are the site admin.
    Only the server operator/administrator can change this setting in the php.ini file.
    You need to ask your host if they can remove the exec function from the disabled_functions part of php.ni.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.