WordPress.org

Ready to get started?Download WordPress

Forums

Requirements for a working trackback (3 posts)

  1. Shelby
    Member
    Posted 9 years ago #

    As some other users before in this forum, the trackback in my installation isn't working when other blogs try to contact my wp-trackback.php. All is coming down to an error 404. The main reason is because of the fancy WordPress feature to use an URI based approach to transfer some variables. Often this is done by a set of GET variables instead. So in WordPress it is wp-trackback.php/23 where some normally would expect something like wp-track.php?p=23.
    I don't know how this feature is exactly called, fact is that the Webserver _should_ know that it has to call the script wp-trackback.php and provide the variables in a field called PATH_INFO. Error 404 in my case means, that the webserver doesn't know that there are parameters appended and tries to call wp-trackback.php/23/index.php which is obviously not there, because wp-trackback.php is a file not a directory.
    Question: Why isn't it working on my www apache but on my apache at home?
    Easy answer: This feature has to be switched on.
    I hope the following is complete, maybe an Apache admin can add or correct my errors:
    For Apache 2.0.30 and above you have to add this to your .htaccess file
    <Files "wp-trackback.php">
    AcceptPathInfo On
    </Files>
    For Apache 2.0.x where x < 30, I don't know. Maybe it's the same as the following.
    For Apache 1.3.x compiled as an Apache handler (see phpinfo() field "Server API") it should always work(?)
    For Apache 1.3.x compiled as CGI there need to be '--enable-discard-path' turned on during compilation (see phpinfo() field "Configure Command")
    If you are in the hopeless situation, that you can't recompile Apache and/or PHP in your environment (like it is the case for the most of us), you still have the opportunity to use mod_rewrite. This also has to be supported by your Apache webserver (see phpinfo()). If it's not in the list, it's not available - and so: are doomed like me. Last possibilty: Edit the trackback feature by your self to use GET variables. There are a few hacks out here in the forum, but I haven't verified them.
    This is only for Apache. Sorry guys, I don't know how it's with your webserver, but maybe here is someone to add some information at least about IIS?
    Conclusion (if my assumptions above are right): WordPress should offer a switch to toggle the trackback between GET and "PATH_INFO".
    Hope to hear some qualified feedback to confirm this, because I am not much in configuring webservers and the above is only a suggestion.

  2. awh
    Member
    Posted 9 years ago #

    According to the Dev Blog, trackback will be working on all URIs in 1.3.

  3. Shelby
    Member
    Posted 9 years ago #

    To clarifiy things for lazy readers: You mean WordPress 1.3, not Apache 1.3 ;)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.