WordPress.org

Ready to get started?Download WordPress

Forums

Required Email in comments Not Working (9 posts)

  1. kabitzin
    Member
    Posted 9 years ago #

    In my options, I have WP set to require an email to be entered along with the name in the comment before the comment will appear, but how can I make it so that readers cannot post comments until they have filled in both the name and the email field.

    I am not using the default Kubrick template (page is at http://www.seaslugteam.com/), and I wanted to make it so that if you left either of those fields blank it take you to a page that said "You must fill in both the name and the email fields" before the comment even got sent to my blog. Thanks!

  2. oriecat
    Member
    Posted 9 years ago #

    Well I just tried to post a comment without leaving an email and I got a page that says "Error: please fill the required fields (name, email)."

  3. kabitzin
    Member
    Posted 9 years ago #

    That's strange... I had about 6 comments on my new install today that got placed right to moderation because they did not have a filled in email field...

    And when I test it myself with a blank email field it lets me post the comment (but it goes straight to moderation).

  4. oriecat
    Member
    Posted 9 years ago #

    Is it people who already have approved comments, or that are logged in?

  5. kabitzin
    Member
    Posted 9 years ago #

    You don't have to be logged in to post a comment, but I have had both people with approved and people without approved comments leave comments without their emails and I don't know how to force the issue.

  6. Cdegenhart
    Member
    Posted 8 years ago #

    I'm getting the same error: "Error: please fill the required fields (name, email)."

    Was this ever resolved? Its very frustrating. I just did the upgrade to 1.5.1.3 and my comments haven't worked since. I turned off the requirement to fill out the name and email fields, but I'd like to actually solve the problem.

  7. MichaelH
    Member
    Posted 8 years ago #

    Cdegenhart--could be a blank user. Check your Admin, Users, Authors&Users and delete any blank user.

  8. Xander
    Member
    Posted 8 years ago #

    I am having this problem now... can't seem to find a solution anywhere I search either (possibly due to the poor state of the search here and everywhere)... is there an easy fix for this one?

  9. Xander
    Member
    Posted 8 years ago #

    Forget it, I guess this is a "feature". WTF.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.