WordPress.org

Ready to get started?Download WordPress

Forums

Advanced CSV Importer With Ultimate User Friendly Features
[resolved] require_once(plugin_deactivate.php): failed to open stream (15 posts)

  1. badbod
    Member
    Posted 7 months ago #

    Hi,
    Cannot deactivate the plugin. Seems to be a missing file?

    require_once(plugin_deactivate.php): failed to open stream

    http://wordpress.org/plugins/wp-ultimate-csv-importer/

  2. hyperhead
    Member
    Posted 7 months ago #

    +1. Me too.

  3. Michael4fm
    Member
    Posted 7 months ago #

    + another 1 .... me too.

    (If anyone else is having this problem and is stuck, an alternative 'work around' is to rename the plugin's directory under ".../wp-content/plugins/..." - e.g. just put an 'x' at the start of the directory name. This will automatically deactivate it when you refresh the plugin page. To reactivate, simply rename the directory back to the original name and activate as usual.)

  4. zacsmith
    Member
    Posted 7 months ago #

    Same problem. Thanks to Michael4fm for info on how to get around the error. I then deleted the plugin. Shame on the developer for releasing plugins that break a site....

  5. Michael4fm
    Member
    Posted 7 months ago #

    @Zacsmith: Well, in fairness to the developer the plugin works - and works well. I've used it SINCE this problem to import a fairly large database in CSV format (several times, actually, as I keep adjusting the database in a different form!)

    It only causes a problem if you want / need to deactivate it. It's a bit unfortunate that this is exactly what you need to do when you're trying to work out which plugin - if any - is causing a particular problem.

    It must be difficult to code for all eventualities, many different server types, versions of PHP, etc. And just the addition or omission of a comma or semi-colon in the wrong place can have some horrible consequences (though usually only temporary .. till you work out where the error is!)

  6. smackcoders
    Member
    Plugin Author

    Posted 7 months ago #

    This bug has been fixed and updated the current version 3.2.0. Kindly update the plugin again.

    Bugs Fixed
    Deactivation Error
    Custom Post Types issue

  7. Michael4fm
    Member
    Posted 7 months ago #

    Thanks, Smackcoders. Certainly seems to have worked for me.

    Minor point but v.3.2.0 was the release that had the problem. Don't know if doing another release - say v.3.2.0.1 - is a huge palava so you've just edited / added / replaced the offending file, but the result is that 're-upgrading' isn't straight forward, nor will notifications be sent out (I think) to anyone who has already upgraded to the version with the bug.

    [If anyone's encountering this problem, the solution is actually quite simple ... delete the "WP Ultimate CSV Importer" plugin via FTP then re-add it as if it were a new one. Don't think there are any settings to worry about losing, but even if there are things should just work as if you've deactivated then reactivated it.]

  8. badbod
    Member
    Posted 7 months ago #

    Michael4fm please don't waste our time.

    Though you are a sock puppet when it pleases you; I do appreciate you fixing stuff.

  9. Michael4fm
    Member
    Posted 7 months ago #

    Hmmm. Not exactly sure how my post was a waste of time.

    I thought I was (1) thanking the developer and confirming the 'fix' worked; (2) Advising them of something they may or may not have been aware of for future upgrades / bug fixes to make users' lives easier; (3) Sharing a simple 'fix' for anyone else that finds this thread who is encountering the issue and doesn't know what to do about it.

    As I have no idea what a sock puppet is (apart from the obvious, obviously) I have no idea whether that's meant to be an insult or a compliment! :-)

  10. jerome45r
    Member
    Posted 7 months ago #

    well...
    i installed the 3.2.0 bugged version few days ago, so i DO have this bug which means that I cannot deactivate the plugin
    but
    i cannot update my plugin to the debugged version as the latest version is still 3.2.0

    please advise

  11. smackcoders
    Member
    Plugin Author

    Posted 7 months ago #

    If anyone's encountering this problem, the solution is actually quite simple ... delete the "WP Ultimate CSV Importer" plugin via FTP then re-add it as if it were a new one. Don't think there are any settings to worry about losing, but even if there are things should just work as if you've deactivated then reactivated it.

    Thanks @Michael4fm/@badbod for doing my job here. Actually we have next release in next couple of days. Quite worried about the bugs and not planned well to update the fix. Just to give a quick fix we updated in 3.2.0 itself.

    @jerome45r just delete the buggy version and reinstall 3.2.0 again. That is simple to go with it.

    And thanks for all who mailed us these issues in time before hitting every one.

  12. Michael4fm
    Member
    Posted 7 months ago #

    @jerome45r: Just delete the plugin via FTP by deleting its directory entry. When you then refresh the plugin page on your dashboard it will have disappeared - you'll get the message 'Plugin WP Ultimate CSV Importer Plugin deactivated as the plugin directory doesn't exist' (or something like that).

    You can then re-add the plugin in the same way you would if it was a completely new one. This will install the new version of v.3.2.0 which has got this bug fixed.

    Key is to be able to access your files via FTP. As long as you can do that, it's easy. If you can't .... errr .... then I'm stuck, to be honest! :-)

  13. smackcoders
    Member
    Plugin Author

    Posted 7 months ago #

    There are some shortcuts

    1. Go to Admin menu >> Plugins >> Editor (/wp-admin/plugin-editor.php) Choose Wp Ultimate CSV Importer from Select plugin to edit drop down and click select. In wp_ultimate_csv_importer.php search and remove or comment this line like this

    //require_once 'plugin_deactivate.php';

    2. To do this via ftp go to your wordpress wp-content/plugin/wp-ultimate-csv-importer/wp_ultimate_csv_importer.php search and remove or comment line no 57.

    //require_once 'plugin_deactivate.php';

    Or else

    3. Create an empty plugin_deactivate.php file in your wordpress wp-content/plugin/wp-ultimate-csv-importer folder.

    This is a quick fix for deactivation issue, but it is highly recommended to deactivate, delete and install 3.2.0 again.

    Note: By couple of day we will release a 3.3.0 with all bugs fixed along with major performance improvements to handle large data import in less time than ever before. Check back for 3.3.0.

  14. jerome45r
    Member
    Posted 7 months ago #

    thanks smackcoders and Michael4fm

    i followed smackcoders instructions and managed to remove the plugin

    thanks again for the help

  15. smackcoders
    Member
    Plugin Author

    Posted 7 months ago #

    So it works, thanks for the update.

Reply

You must log in to post.

About this Plugin

About this Topic