WordPress.org

Ready to get started?Download WordPress

Forums

SSH SFTP Updater Support
[resolved] require_once error (3 posts)

  1. icc97
    Member
    Posted 1 year ago #

    I've just solved a maddening error, so if you get the following error:

    require_once(Net/SFTP.php)

    Then the likelihood is that your apache settings are preventing the PHP function set_include_path from working (http://www.php.net/manual/en/function.set-include-path.php#92504). I'm using Plesk and had the include_path PHP setting set. This prevents set_include_path from working, which knackers this plugin and quite a few other bits of software.

    By unsetting the include_path apache config value this plugin worked again.

    http://wordpress.org/extend/plugins/ssh-sftp-updater-support/

  2. TerraFrost
    Member
    Plugin Author

    Posted 1 year ago #

    Didn't know that setting the include_path via php.ini could prevent set_include_path() from working. Interesting..

    Anyway nice find!

  3. icc97
    Member
    Posted 1 year ago #

    I think its actually in the apache config file (or .htaccess file) rather than in the php.ini file. Plesk allows differing PHP settings for each Virtual Host on the server - so I suspect that they have some apache config magic somewhere buried, but its difficult to figure out where they put it. Perhaps the php.ini file might knacker it too, but I haven't tested that.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic