WordPress.org

Ready to get started?Download WordPress

Forums

bbPress Topics for Posts
[resolved] Reposts upon post edit (8 posts)

  1. Erlend Sogge Heggen
    Member
    Posted 1 year ago #

    I just made a new post that creates a new bbPress thread for comments. Every time I make an edit to the post it creates another bbPress thread, like /newthread-2 and /newthread-3.

    Using latest version of WordPress, bbPress and this plugin.

    http://wordpress.org/extend/plugins/bbpress-post-topics/

  2. Erlend Sogge Heggen
    Member
    Posted 1 year ago #

    Has no one else experienced this?

  3. David Dean
    Member
    Plugin Author

    Posted 1 year ago #

    Hi, Erlend -

    No one has reported anything like that in a while, then you and bennygill did about a month ago. I haven't been able to reproduce the problem, though.

    Can you provide any details about your publishing workflow? Are you using an external program to publish / edit? Are there any other workflow plugins involved?

    These would all be helpful for narrowing down the source of the trouble.

    Thanks for reporting this and please let me know if you run into anything else!

    - David

  4. Erlend Sogge Heggen
    Member
    Posted 1 year ago #

    I experienced it again on my site today. The annoying thing is I can't for the life of me reproduce it. I tried retracing my steps down to the last tag submitted, but I can't make this bug appear when I want it to!

    All I know is, the bug will occur when for some reason, you're stuck at "Create a new topic in forum" even after you've published and/or updated your post, like this:
    http://i.imgur.com/HllnqAe.png

    Whenever it's working right, after publishing the slug of the auto-created topic has been automatically added to the "use existing topic" slot and the other option is set to "Select a forum".

  5. Erlend Sogge Heggen
    Member
    Posted 1 year ago #

    I managed to consistently reproduce it! Here ya go:
    http://www.screenr.com/y2y7
    (you can just mute the static. I forgot to turn audio recording off).

    To be exact, it's the "Use default display settings" being unchecked upon saving draft that does it. If you don't have that checked when you save a draft, the entire "Use a bbPress forum topic for comments on this post." will automatically be unchecked upon saving the draft.

  6. David Dean
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Erlend,

    Nice! Thanks for going to the trouble of figuring out how to reproduce it. I'll take a look and hopefully have a fix out in the next couple days. The issue of needing to uncheck "Use default display settings" in order to keep the overall settings active is a problem, too, but not as bad as duplicate topics.

    I'll keep this topic updated as fixes are checked in to the development version and once a new release is out!

    - David

  7. David Dean
    Member
    Plugin Author

    Posted 1 year ago #

    It looks like draft settings are not being deleted when they're supposed to. The good news is that affected posts will stop creating duplicate topics once you're running the next release.

    The fix has been added to the development version if anyone wants to try it out. A full release will be out soon.

  8. David Dean
    Member
    Plugin Author

    Posted 1 year ago #

    This is fixed in 1.7. Please let me know if you run into anything else!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic