WordPress.org

Ready to get started?Download WordPress

Forums

Repost - Please help with Installation! PHP errors. (15 posts)

  1. jblue
    Member
    Posted 8 years ago #

    I posted some days ago but didn't seem to get more than one reply. I have tried to install WordPress a number of times now. I have changed only the database info in the wp-config.php file, and put a new prefix to add a new table. I have downloaded new copies with each installation, and I'm still getting the same error messages. I'm posting the content of my file here so people will know that I didn't change anything to do with any languages (nor did I touch any other file but the wp-config.php file).

    <?php
    // ** MySQL settings ** //
    define('DB_NAME', 'jblue'); // The name of the database
    define('DB_USER', 'jblue'); // Your MySQL username
    define('DB_PASSWORD', 'fakepassword'); // ...and password
    define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value

    // You can have multiple installations in one database if you give each a unique prefix
    $table_prefix = 'knitblog2_'; // Only numbers, letters, and underscores please!

    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-includes/languages.
    // For example, install de.mo to wp-includes/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', '');

    /* That's all, stop editing! Happy blogging. */

    define('ABSPATH', dirname(__FILE__).'/');
    require_once(ABSPATH.'wp-settings.php');
    ?>

    Then when I tried and run the install.php file I get this:

    Warning: Unable to access /home/jblue/public_html/knit2/wp-includes/languages/en_US.mo in /home/jblue/public_html/knit2/wp-includes/wp-l10n.php on line 66

    Warning: Cannot add header information - headers already sent by (output started at /home/jblue/public_html/knit2/wp-includes/wp-l10n.php:66) in /home/jblue/public_html/knit2/wp-admin/install.php on line 16

    WordPress

    Welcome to WordPress installation. We’re now going to go through a few steps to get you up and running with the latest in personal publishing platforms. You may want to peruse the ReadMe documentation at your leisure.
    First Step »

    That's it. I have tried from both a Mac and PC, using Wordpad, BBEdit, anything I can. Is the problem with the server? I know we have PHP installed.

    If anyone can help, I'd really appreciate it! This is extremely frustrating. I'm not PHP expert but I do web design and coding so I know I haven't changed anything in the code that I shouldn't have. Thank you.

  2. Samuel Wood (Otto)
    Tech Ninja
    Posted 8 years ago #

    Is the wp-includes/languages/en_US.mo file actually there? Also check to see if it has the correct permissions.

  3. Doodlebee
    Member
    Posted 8 years ago #

    Is it giving you an error message, or just stopping at the "first step" page and not going any further?

    If ti's just stopping with no error messages, then you need to ask your host to turn your error reporting "on" in PHP. Then you'll see the error message, and it'll tell you *exactly* what's wrong.

  4. jblue
    Member
    Posted 8 years ago #

    No, the languages folder/file is NOT there, as it doesn't come with the downloaded files. Is it supposed to be there and that is the problem?

    It gives that error, and then it goes through with the install with those same errors, but then I can't get to any interface after it gives me a password.

    I will ask about error reporting, thanks.

  5. jblue
    Member
    Posted 8 years ago #

    OK - just to be sure - I continued with the installation despite that header/language message - and it did give me a password, and when I try to log in, I get this:

    Warning: Unable to access /home/jblue/public_html/knit2/wp-includes/languages/en_US.mo in /home/jblue/public_html/knit2/wp-includes/wp-l10n.php on line 66

    Warning: Cannot add header information - headers already sent by (output started at /home/jblue/public_html/knit2/wp-includes/wp-l10n.php:66) in /home/jblue/public_html/knit2/wp-login.php on line 9

    Warning: Cannot add header information - headers already sent by (output started at /home/jblue/public_html/knit2/wp-includes/wp-l10n.php:66) in /home/jblue/public_html/knit2/wp-includes/pluggable-functions.php on line 274

    Warning: Cannot add header information - headers already sent by (output started at /home/jblue/public_html/knit2/wp-includes/wp-l10n.php:66) in /home/jblue/public_html/knit2/wp-includes/pluggable-functions.php on line 275

    Warning: Cannot add header information - headers already sent by (output started at /home/jblue/public_html/knit2/wp-includes/wp-l10n.php:66) in /home/jblue/public_html/knit2/wp-includes/pluggable-functions.php on line 247

    Now, I know to look for extra whitespace, etc. with the header problem, but I'm not finding any. All those files are uploaded straight from the WordPress download, they've not even been opened in any editor. I'm flummoxed, and really bummed, as I'd love to migrate my blog over from Movable Type. But it's looking more and more like I'm gonna have to stay with that.

  6. Doodlebee
    Member
    Posted 8 years ago #

    I found another thread for the same issue (unknown if the results came out okay) - but I guess there's a place in teh config.php file where you can modify your language setting? (WPLANG)?

    DId you try to enter in "english"? Because english is the defualt, and there's no need to have that setting in the file - if you put in a setting, it's looking for your language folder, which you don't have, and is causing the errors.

    If it makes you feel better, I don't have the language folder, either - but my installation is running fine and dandy. If it helps, this is what my file looks like (passwords and such are replaced with "XXX"!)

    <?php
    // ** MySQL settings ** //
    define('DB_NAME', 'XXX'); // The name of the database
    define('DB_USER', 'XXX'); // Your MySQL username
    define('DB_PASSWORD', 'XXX'); // ...and password
    define('DB_HOST', 'XXX'); // 99% chance you won't need to change this value

    // You can have multiple installations in one database if you give each a unique prefix
    $table_prefix = 'wp_'; // Only numbers, letters, and underscores please!

    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-includes/languages.
    // For example, install de.mo to wp-includes/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', '');

    /* That's all, stop editing! Happy blogging. */

    define('DISABLE_CACHE', true);

    define('ABSPATH', dirname(__FILE__).'/');
    require_once(ABSPATH.'wp-settings.php');
    ?>

    Maybe you can compare my config file to yours and see what the differences are?

    And since the "headers are already sent" issue is *after* this languages issue - chances are that when you fix the languages thing, everything else will fall into place.

    Let us know if that helped!

  7. jblue
    Member
    Posted 8 years ago #

    Thanks Doodlebee - but no, I did not try to enter any English or any language file. The language area in my file looks the same as yours. I only changed database user name, password, and the prefix for the table (since I have more than one blog using the database).

  8. Doodlebee
    Member
    Posted 8 years ago #

    Hmm...

    well, here's a link to a thread that may help...

    give it a try?

  9. jblue
    Member
    Posted 8 years ago #

    Thank you! I will certainly try that and report back.

  10. jblue
    Member
    Posted 8 years ago #

    Well, no go, that fix didn't work for me at all. I tried the blank language file and commenting out that code but it made a bigger mess.

    I'm really at a loss here. We have a SunOS server with PHP 4.2.3. Is anyone else using that configuration with success?

  11. Doodlebee
    Member
    Posted 8 years ago #

    I'm using the same version of PHP on my seerver *and* my localhost setup - it runs fine on both.

    Here's a question...I just noticed you said this in your original post:

    >>I have tried to install WordPress a number of times now. I have changed only the database info in the wp-config.php file, and put a new prefix to add a new table.<<

    By chance, was there already a wordpress installation on the server? one already there and running? You mention you wanted more than one set of tables for WordPress - an attempt at making a multiple installation on one database...

    could it be that you don't have your prefixes correct? I think the line needs to read like so:

    // You can have multiple installations in one database if you give each a unique prefix
    $table_prefix = 'wp_'; knitblog2_'; // Only numbers, letters, and underscores please!

    And that will give you your two installations. Maybe that's the issue?

  12. moshu
    Member
    Posted 8 years ago #

    $table_prefix = 'wp_'; knitblog2_'; //

    I don't think that would work. Multiple means - WP files installed as many times as many blogs you want each with separate config file!

  13. moshu
    Member
    Posted 8 years ago #

    have a SunOS server
    Is gettext running on that server?
    Gettext is the technology used for the internationalization (i18n) and localization (l10n):
    http://www.gnu.org/software/gettext/

  14. jblue
    Member
    Posted 8 years ago #

    I don't know if Gettext is installed - I'll try to find out, thank you.

    The reason for the multiple installs is that it didn't work the first time, or the second - so each time I tried to install again I had to give it a new table prefix or it would tell me it was already installed but yet I can't log in and get to any interface.

    I do also have a Movable Type blog running - but from what I understand, that shouldn't be a problem.

  15. Doodlebee
    Member
    Posted 8 years ago #

    So, when you reinstalled the second (and third, etc.) times, you didn't delete the tables and such from your database?

    Maybe you should just delete the whole database from your server, create a new one and start from scratch? I don't think installing it over and over again with new prefixes is going to help much.

    (By the way, I also have 3 MT blogs on my server, along with a pMachine and this WordPress install - none have collided with each other at all.)

Topic Closed

This topic has been closed to new replies.

About this Topic