WordPress.org

Ready to get started?Download WordPress

Forums

WP-Ajaxify-Comments
[resolved] Replies not attached to main comment (5 posts)

  1. sunscream
    Member
    Posted 1 year ago #

    Having a weird issue. Logged in, I can use the ajaxify comment plugin just fine to reply to other comments.

    However, when I try it as a non-logged in user, it'll show as a new comment, not as a reply. Can't figure out why.

    http://wordpress.org/extend/plugins/wp-ajaxify-comments/

  2. janjonas
    Member
    Plugin Author

    Posted 1 year ago #

    Could you please send me a link to the page where I can reproduce the problem?

  3. sunscream
    Member
    Posted 1 year ago #

  4. janjonas
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks for your comment. Are you sure that the problem is caused by the WP-Ajaxify-Comments plugin?

    You can use the browser console and test the result of $("#comment_parent").val(). After clicking a reply link the result is "0", after clicking the same reply link again or another reply link, the result changes to a value > 0. In result, after clicking the reply link twice the comment should be saved correctly as reply (even with WP-Ajaxify-Comments enabled).

    Could you please test if you can reproduce this behavior and test if disabling the WP-Ajaxify-Comments plugin rely fixes the reply function (when clicking the reply link only ones)?

    Hope this helps...

  5. sunscream
    Member
    Posted 1 year ago #

    You're right. Doing some more digging and checking comment_parent, I realize there were two of them. One from a hidden form, another from the real form.

    Turns out I had a spammer plugin that used a red herring form and this was interfering with comment replies.

    Didn't notice this before because logged in users don't get served the form and I was almost always logged in.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic