WordPress.org

Ready to get started?Download WordPress

Forums

Removing /wordpress from site URL (8 posts)

  1. olsonea
    Member
    Posted 1 year ago #

    Ubuntu Server LTS
    Apache 2
    Wordpress 3.3.1

    I'm trying to remove the /wordpress from my site URL, so that users can go to http://www.olsonea.com instead of http://www.olsonea.com/wordpress. I've tried following the directions in the link on the Settings > General page, but to no avail. When I do that, and go to http://www.olsonea.com, I just receive the default Apache "It Works!" landing page.

    Is there something I am missing? Do I need to play around with vhosts? Thanks in advance.

  2. olsonea
    Member
    Posted 1 year ago #

    Ubuntu 12.04.1 LTS... sorry

  3. ClaytonJames
    Member
    Posted 1 year ago #

    If you have installed WordPress on Ubuntu using the apt package manager, (apt-get install wordpress) then I'm afraid you're probably stuck with the default path. Aptitude installs WordPress using a variety of symlinks and Ubuntu specific configuration files. If I remember correctly, the installation forces a symlink to /usr/share/wordpress where I believe the files are actually installed, rather than allowing them to be served from the default container at /var/www. You may also find that your version of WordPress will (most probably) never be current if installed or updating from a Ubuntu repo.

    [edit] I just checked the WordPress package in the Ubuntu 12.04 repo. It appears to be wordpress 3.3.1+dfsg-1

  4. olsonea
    Member
    Posted 1 year ago #

    Ah ha! I did in fact install WP using apt-get install wordpress. Since I'm basically just getting started, is my best option to do a reinstall, download the WP tarball, and unzip it directly in/var/www?

  5. olsonea
    Member
    Posted 1 year ago #

    Or, do I even need to do a reinstall? Can I drop the symlink, and just unpack the tarball in /var/www, and go from there? Will I want to drop the wp database in MySQL?

  6. ClaytonJames
    Member
    Posted 1 year ago #

    My advice (without knowing how much time you have invested, or how familiar you are with Ubuntu, or Apache, MySQL, and database administration) is to completely uninstall WordPress using aptitude, and then simply re-install WordPress (properly) and serve it from /var/www in the default site container. I think you might find the default config somewhere around /etc/apache2/sites-enabled/default

  7. olsonea
    Member
    Posted 1 year ago #

    Just wanted to say thank you, and let you know that worked out perfectly!

  8. ClaytonJames
    Member
    Posted 1 year ago #

    You're welcome. I'm glad it worked!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.