WordPress.org

Ready to get started?Download WordPress

Forums

Removing the www prefix (6 posts)

  1. Edo Dijkgraaf
    Member
    Posted 1 year ago #

    Hi,

    My wife's a primary school teacher. Until last week they had a Joomla! website. I am making them a WordPress website.
    I have made several multisite websites. Now I experience a difficulty which is maybe nothing, but I am not sure. During the proces I get this message. After I added:

    define('WP_ALLOW_MULTISITE', true);

    I go to Tools > Network Setup. I choose Subdomains.

    This is part of a screen dump, but it's in Dutch:
    http://www.cbsdekameleon.nl/wp-content/uploads/2012/09/server-address.png

    It says it was strongly recommended to remove the www-prefix first.

    If I change the url to http://cbsdekameleon.nl in Settings I get kicked out of the Administration.

    In this stage my .htaccess is not changed yet, because of the recommendation to remove the prefix (www) first. The .htaccess looks like this:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    This is the first time I get this message, but for the other multisites I made I never registered as www. Or maybe I never read well during the conversion to multisite.

    What am I doing wrong?

    The webhost is xs4all.nl.

  2. Pothi
    Member
    Posted 1 year ago #

    Whatever you have done so far and whatever you have described so far is what one could expect while trying to install it on a domain with www prefix.

    If I change the url to http://cbsdekameleon.nl in Settings I get kicked out of the Administration.

    Once you got kicked out, can you login again? If yes, just login and do the usual steps to enable (and install) Multisite.

  3. Edo Dijkgraaf
    Member
    Posted 1 year ago #

    Thank you for replying Pothi.

    I can only login if i choose:

    WordPress address (URL): http://www.cbsdekameleon.nl
    Website address (URL): http://cbsdekameleon.nl

    If I change the WordPress address to http://cbsdekameleon.nl the only way to get back in, is by changing the url in the database wp_options back to http://www.cbsdekameleon.nl

    If I do so I get the message in Network Setup that the WordPress address and the website address have to be the same.

  4. WordPress address (URL): http://www.cbsdekameleon.nl
    Website address (URL): http://cbsdekameleon.nl

    This must be done before you set up Multisite, or you're in for a world of hurt.

    Change those BOTH to http://cbsdekameleon.nl

    Now I noticed that http://cbsdekameleon.nl doesn't work, which means your server was setup stupidly (yes, stupid, it's like making a lightswitch that does nothing, bad server admin, no cookies).

    You'll need to do this in your .htaccess (at the very top)

    http://perishablepress.com/stupid-htaccess-tricks/#red2

  5. Edo Dijkgraaf
    Member
    Posted 1 year ago #

    I did what you told me to do. Changed the .htaccess

    "Not much luck"

    If I upload the old .htaccess it seems like the xs4all-servers need some time. After five minutes or so the website is available again. (Ofcourse I removed my cash first and also tried another browser.)

    I checked my own website's .htaccess. I thought maybe one of my plugins had taken care of the rewriting, but no. My host is probably a lot better, or let's say more user friendly. My own website has way heavier, but reacts much quicker. One cannot refuse to help a primary school. But I have learned my lesson.

    I will ask the teacher in charge of the website to call the hosting provider to ask to change the settings.

    Thx so far!

  6. Yeah, you need to get DNS redirection working. There's absolutely no reason that www shouldn't redirect to the non-www (or vice versa, just pick one man). Having http://www.domain.com just FAIL is bad server admining :)

Topic Closed

This topic has been closed to new replies.

About this Topic