WordPress.org

Ready to get started?Download WordPress

Forums

Removing the old version of the plugin failed (14 posts)

  1. jah
    Member
    Posted 6 years ago #

    This worked for me in 2.5 and 2.5.1 but broke in 2.6.

    Now whenever I try to automatically upgrade a plugin, I get this:

    Downloading update from http://downloads.wordpress.org/plugin/bad-behavior.2.0.20.zip

    Unpacking the update

    Deactivating the plugin

    Removing the old version of the plugin

    Could not remove the old plugin

    Installation Failed

    I tried playing with permissions on the plugin folder and on the plugin and on the plugin folder and its contents (in a test installation), but I get no joy.

  2. jah
    Member
    Posted 6 years ago #

    Anybody got a clue?

  3. hotkee
    Member
    Posted 6 years ago #

    Just update it manually, its the plugin thats failing, not wordpress - you will get the odd hichup.

  4. jah
    Member
    Posted 6 years ago #

    I have updated manually, but it's not the plugin that's failing. None of the plugins will update on any of three blogs.

  5. hotkee
    Member
    Posted 6 years ago #

    Cant really tell as it could be anything - maybe your upgrade to 2.6 wasnt right, usually people miss files or dont overwrite files. Sorry cant really tell without more information.

    Someone else might know of course!

  6. jah
    Member
    Posted 6 years ago #

    I'd love to give more information to anybody who knows what information they'd need. This is very frustrating.

    I have three different blogs. One of them I upgraded using the auto upgrade plugin and the other two I used fantastico. I'll try (re)upgrading one by hand to see if that changes anything, but I can't see how it would.

  7. jah
    Member
    Posted 6 years ago #

    Anybody?

  8. alinush
    Member
    Posted 5 years ago #

    The exact same thing happens to me with WP Super Cache and other plugins...it worked when I had 2.5.1, but now doesn't work with 2.6 :(

    I updated from 2.5.1 to 2.6 using the Automatic WordPress Update plugin

  9. Halibutt
    Member
    Posted 5 years ago #

    I guess it's a known bug - too bad nobody has a clue how to solve it...

  10. jerrybell
    Member
    Posted 5 years ago #

    I have had this problem for a while. I took some time and tracked down the problem and a fix. I have a write up here: http://www.jerry-bell.com/fix-for-wordpress-could-not-remove-the-old-plugin-error/

    I hope that fixes it for you as well.

  11. gmustuk
    Member
    Posted 5 years ago #

    Jerry....I have the same problem....and this happens to just about all the plugins that I install through the admin interface.

    If I try to upgrade the plugin after the install it won't work. Basically it seems that it uses the servers security credentials rather than the general FTP account credentials so when you try to upgrade (using the FTP info that wordpress asks for) it doesn't have access. I have to login with a root login...delete the plugin...and then manually ftp upload/activate the plugin.

    I'm searching for a solution, but there needs to be a way to have control over what user/group the plugin files/dir are created with so that upgrades can properly remove and replace the plugin with the same access account.

  12. scifisi
    Member
    Posted 5 years ago #

    Yes indeed, I am new to WordPress but not new to IT. I'm a sys admin and web designer. v 2.7.1 won't upgrade ANY plugin at all - no matter how it's installed.

    I'm hosting WP on my server at home not an ISP's. I'm certain is an OS permissions thing. I'll have a quick look...

    Humm. I could change the permissions of the 'Everyone' group to be able to write - but this would be a major security issue.

    I can't see anywhere that WordPress asks for a username and password of an account that can be used to update the plugins with - I guess this is a feature that doesn't work at the moment or hasn't been implimented.

    JerryBell - Thank's but that is not a scenario many people are likely to have, by the looks of it no one else has multiple directories created and it's not a plug-in problem. I'm hosting 25 websites and using 30 plugin's. It IS a WordPress problem. WP NEEDS to specify a user/pass to the OS to update the plugins with it's as simple as that.

    Will post back if I find a solution/workround

  13. scifisi
    Member
    Posted 5 years ago #

    Ok solved it.

    I think I was just too lazy to bother looking for the solution for this, but now that I have, I thought I'd post the actual and working solution here, though I don't think many will like it.

    YES. It is an OS privilidge issue. Simply locate the plugins directory for your blog, right click and select properties.

    Under the Security tab the

    'Everyone' user needs to have 'Modify' privilidge set to ALLOW.

    This will fix the problem for everyone. If this works for you - please visit my site and consider what my advertisers have to say :)

    http://caspianit.co.uk

    Thank's for your support

  14. swiss420
    Member
    Posted 5 years ago #

    Has anyone found a different solution that does not leave the Blog unsecured?

    "This will fix the problem for everyone. If this works for you - please visit my site and consider what my advertisers have to say..."

    again a bad advise. Offering a false Solution and hoping to profit from it is just plain wrong.

    For me the Error occured after upgrading to 2.8.0 and has persisted through 2.8.1 and 2.8.2. It seems to be happening with different Versions of WordPress and in my case downloads the Plugin to the /wp-content/upgrade/Pluginname/Pluginname/ directory and brings a error message saying:

    Neues Paket wird entpackt.
    Neueste Version wird installiert.
    Alte Version des Plugins wird entfernt.
    Alte Version des Plugins konnte nicht entfernt werden.
    Die Aktualisierung des Plugins ist fehlgeschlagen.
    New Package is being unpacked.
    Newest Version is being installed.
    Old Plugin is being removed.
    Old Version of the plugin could not be removed.
    The update has failed.

    Or something like that in English.

Topic Closed

This topic has been closed to new replies.

About this Topic