WordPress.org

Ready to get started?Download WordPress

Forums

removing special characters (17 posts)

  1. djstreet
    Member
    Posted 7 years ago #

    is there a plugin that will prevent wordpress from chanigng ' and " to html & # 8 2 1 7 ; (without spaces) and such? For the purpose of SEO it's a real pain to have great content but confusion between ' and & # 8 2 1 7 ;

  2. Kafkaesqui

    Posted 7 years ago #

    TextControl may be want you're looking for:

    http://dev.wp-plugins.org/wiki/TextControl

    Once you have it installed on your blog, set it to 'no character encoding' (it's wptexturize that's doing the conversion to character entities).

  3. dmatlis
    Member
    Posted 7 years ago #

    Will this also take care of the    and the special characters that appear when you enter quotes or other pontuation marks?

  4. That sounds like a character encoding issue, but we can only guess because you have not provided a link to your site.

  5. djstreet
    Member
    Posted 7 years ago #

    The text control worked perfectly (so far) thank you.

  6. dmatlis
    Member
    Posted 7 years ago #

    Here is a link to my site.
    http://ls-panorama.axendia.com

    You can see the    and also I get “ when i put in double quotes.

  7. moshu
    Member
    Posted 7 years ago #

    For some strange reason you don't have the character encoding defined in your header... Did you remove it or was the theme designed that badly?

    On the single post view like this:
    http://axendia.com/blog/2006/11/09/bio-strategy-partners-adds-axendia-to-member-roster/
    the encoding seems to be utf-8 (that's what the browser says), while on the main page you just linked above
    http://ls-panorama.axendia.com/
    the encoding is iso-8859-1 (western).

    This kind of mismatch is always a sure recipe for wierd characters...

  8. Samuel B
    moderator
    Posted 7 years ago #

    Are you running version 2.0.3 by any chance?

  9. dmatlis
    Member
    Posted 7 years ago #

    I am running version 2.0.2

    I did not remove any the encoding from the header. I am using the tiga theme which I dounloaded from the theme gallery.

    In any case, how do I add the utf-8 encoding to the main page?

  10. moshu
    Member
    Posted 7 years ago #

    Add this to the header.php of the theme:
    <meta http-equiv="Content-Type" content="text/html; charset=<?php bloginfo('charset'); ?>" />
    e.g. just under the <title> tag would be fine.
    Then make sure in the admin > Options > Reading the proper encoding is selected.

  11. dmatlis
    Member
    Posted 7 years ago #

    OK, I will try that.

    Reading encoding is set to UTF-8

    Thanks

    Dan

  12. dmatlis
    Member
    Posted 7 years ago #

    I tried adding the call where you suggested, but no luck.

    I see what you mean, when I change the encoding on the browser to UTF-8 it looks fine.

    Is there another way to set the encoding?

  13. moshu
    Member
    Posted 7 years ago #

    Are you sure you are not seeing a cached version? Did you try Ctrl+F5?
    I am seeing your main page without the strange characters and the site is "sending" out the right information about the encoding - utf-8. I don't have to change anything in my browser's settings. The browser can detect the encoding.

  14. dmatlis
    Member
    Posted 7 years ago #

    Sorry, disregard the last message, I added the statement inside of the <Title> section.

    I moved it to a "good" place and I seems to be working fine.

    Thanks a lot.

    DAN

  15. journeyguy
    Member
    Posted 6 years ago #

    This is the exact problem I'm having with a new theme I'm working on. I tried the above and it didn't work...

    Help!

  16. moshu
    Member
    Posted 6 years ago #

    What is the "exact problem", which theme and where (=link)?

    "Didn't work" means nothing.
    Be specific if you want sepcific help.
    Otherwise you will just be told how to post :)

  17. journeyguy
    Member
    Posted 6 years ago #

    I've solved this... Somehow or another I had a font conflict with Arial on my Mac.

Topic Closed

This topic has been closed to new replies.

About this Topic