WordPress.org

Ready to get started?Download WordPress

Forums

Removing Pinterest "nopin" from head (13 posts)

  1. tnybits
    Member
    Posted 1 year ago #

    Hello, I found out I cannot pin to pinterest and found

    <meta name="pinterest" content="nopin"/></head>

    ending my <head> tag. I never added this to my site nor can i edit it directly from the theme's header. I also am unable to find it in general-template.php

    Any suggestions?

    Site: TnyBits.com

  2. tnybits
    Member
    Posted 1 year ago #

    Update: I have added a Test line right before the </head> and it ended up looking like this:

    test
    <meta name="pinterest" content="nopin"/></head>

    So this is not located in wp_head

  3. smkyle1
    Member
    Posted 1 year ago #

    I have the same problem. I'm using Genesis with a child theme. The support at Genesis tell me the tag was added when I installed a plugin. The also said that because the plugin added the meta tag, the only way to remove it is to deactivate the plugin. I deactivated all of my plugins and no luck. I'm still looking for a solution.

  4. Andrew
    Forum Moderator
    Posted 1 year ago #

    We don't support Genesis.

  5. smkyle1
    Member
    Posted 1 year ago #

    I contacted the support team at StudioPress (the developers of Genesis). They maintain that their themes are not the source of the problem. They say the problem must be coming from a plugin. This is not a Genesis issue.

  6. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Try deactivating your plugins and switching to the default WP theme - right now you have quite a few plugins active - maybe Shareholic is adding that code?

  7. smkyle1
    Member
    Posted 1 year ago #

    thank you WPyogi --

    As soon as I realized the Pinterest button wasn't working, I contacted Shareholic tech support (before contacting anyone else). They were the ones who identified the metatag in my header.

    <meta name="pinterest" content="nopin"/></head>

    Here are the things I've already done:

    1) Deactivated all plugins (with the exception of the Pinterest button plugin)
    2) Reverted to the default WP Theme Twenty Eleven
    3) Validated my site for Pinterest
    4) Initiated tickets with my host, Pinterest, the theme developer company, and others.

    Speaking of the no pin meta tag, StudioPress tech support said:

    That is the rendered HTML source of the page after all the code runs. It does not say what plugin or action has added the code.

    Unless someone manually added it to the theme files, I really have no idea where it is. We do not add that code to the theme files.

    So I'm still stuck at square one. I want to permit pinning but somehow there is a line of code that is preventing that from happening and I have no idea how to remove it.

  8. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Try deactivating all the plugins by resetting the plugins folder- using FTP, rename the folder to something else (temporarily).

    Can you post a link to your site with NO plugins and the default (twentytwelve) theme?

  9. smkyle1
    Member
    Posted 1 year ago #

    Thank you -- I will follow your recommendations but I have to wait until the site is getting less traffic. I work on it in the wee hours of the morning.

  10. smkyle1
    Member
    Posted 1 year ago #

    by the way, the originator of this thread TnyBits.com has found a remedy -- or at least it looks like it because I went to his/her site and tested the Pinterest button. It works fine. I wanted to contact this person but there isn't a contact button on the site and I don't think I can contact them through this site. Maybe the WPyogi or Andrew Nevins can contact this person to find out how they discovered a solution.

  11. tnybits
    Member
    Posted 1 year ago #

    Hi, just FYI there is a contact form on our site (we use infinite scroll so its kind of hard to see)

    Can i get the URL to your site please so i could take a look if we actually have a similar issue?

  12. smkyle1
    Member
    Posted 1 year ago #

    Thanks so much. Here is my url

    http://www.laprogressive.com

  13. tnybits
    Member
    Posted 1 year ago #

    Ok well the cause of my problem was actually cloudflare. There is an option somewhere which caused the no pin meta to be inserted. I can't tell if you are using cloudflare but that's what was causing my problems.

Topic Closed

This topic has been closed to new replies.

About this Topic