WordPress.org

Ready to get started?Download WordPress

Forums

Removing index.php from Permalinks (4 posts)

  1. resoundsw
    Member
    Posted 1 year ago #

    I want to change permalinks to use a format of http://www.myurl.com/postname. But, it always wants to include index.php in that url: http://www.myurl.com/index.php/postname.

    How can I remove index.php from that permalink? I've found documentation saying that it's an "Almost Pretty" format, but how can I change to "Pretty Permalinks?"

  2. WPProHelp
    Member
    Posted 1 year ago #

    Hi,

    Did you configure permalinks yourself? I would recommend you to:

    1. Make a backup of the htaccess file you have in your wordpress root
    2. Navigate to the permalinks settings in the WordPress dashboard.
    3. Navigate to the Permalinks settings in the WordPress dashboard and select "custom Structure" and enter the following: /%postname%/

    That should do the trick for you. Hope it helps!

  3. resoundsw
    Member
    Posted 1 year ago #

    I had already tried this resolution. But, the existing pages now give me a "This page cannot be found" error.

    When initially setting up this WordPress site a couple days ago, I changed permalinks from the default to using the post name structure. Then, I notice it was adding index.php to the url and tried using the custom structure (same way you mentioned above). But, that broke the links to the pages.

  4. fonglh
    Member
    Posted 1 year ago #

    http://codex.wordpress.org/Using_Permalinks

    Your web server must meet the requirements.

Topic Closed

This topic has been closed to new replies.

About this Topic