WordPress.org

Ready to get started?Download WordPress

Forums

removing dotted line from custom menu widget (14 posts)

  1. momentumkris
    Member
    Posted 1 year ago #

    Hi all,

    I am running Genesis theme with the Prose child theme. I am trying to create an accordian menu using the Jquerty Accodian Menu Widget plugin.

    It seems to be working as it should, but I have incredibly hack looking dotted lines underneath every menu item. I do not know if these dotted lines are from the theme, child, widget, or menu widget plugin, and for the life of me I cannot find where to take them away. I have taken off just about every option for a dotted line that I can find in my theme settings and Design settings but they just won't go away.

    I am not good with code, but I can follow instructions if I have to do this manually.

    Here is my site: You can see the sidebar menu on the left is the one with the dotted line problem. http://www.momentummartialarts.ca/saskmaa

    Thank you in advance!

  2. Aaron
    Member
    Posted 1 year ago #

    Edit your CSS in style.css, child theme, or custom CSS in theme options with the below. I do not know your theme so I don't know what methods are available for you.

    #nav li a:hover, #nav li a:active, #nav .current_page_item a, #nav .current-menu-item a {
    text-decoration: none;
    }
  3. momentumkris
    Member
    Posted 1 year ago #

    Hi, thanks. Do I have to add this code anywhere specific? Can I just add it at the end of the style.css file?

    EDIT: I just tried to edit the style.css file for my child theme (prose). I added this code to the end of the file, and saved/uploaded it. It does not seem to have worked; the lines are still there.

  4. Aaron
    Member
    Posted 1 year ago #

    You can just add at the end to make it work.

  5. Aaron
    Member
    Posted 1 year ago #

    I don't see where you added it at.

  6. momentumkris
    Member
    Posted 1 year ago #

    What I did was go into my prose folder, Prose being the child theme, and downloaded the style.css locally. I then opened the style.css in notepad and cut and pasted your code after the very last line in that file. I saved it, closed it, and re-uploaded it to the same folder on my site.

    Is that how I should be editing the style.css file?

    EDIT: I also just tried it another way. I went to the custom code section of my theme settings and cut and paste your code into the custom css area. It still doesn't seem to have an effect.

  7. Aaron
    Member
    Posted 1 year ago #

    In wp-admin go to appearance > editor and select the stylesheet on the right side.

    Add it to the bottom of there.

  8. momentumkris
    Member
    Posted 1 year ago #

    When I went to Appearance > Editor and scrolled to the bottom, the code is already there. It still has no effect though.

  9. Aaron
    Member
    Posted 1 year ago #

    Not sure how the theme works since it is a premium theme and we don't have access to the files. I would recommend contacting the people you bought it from for support.

    Typically we only support free themes due to this reason and others but I thought Id give it a shot.

  10. momentumkris
    Member
    Posted 1 year ago #

    I will do that Aaron. Thank you for trying, I appreciate it.

  11. Dominor Novus
    Member
    Posted 1 year ago #

    It seems like a basic issue that can probably be resolved by looking at the CSS using Chrome's of Firefox's property inspector (e.g. Firebug).

    If I could actually see the problem you're describing, I could help out.

    My guess is that dotted line is either a border or an image.

    Advise me on how to reproduce the issue and confirm that the issue is consistent on all browsers and I'll have a look.

    Aaron Nimocks' advice on premium support stands. If you paid for it, support is expected from the seller.

    Incidentally, in my opinion, Thematic is great, free and well supported framework:
    http://wordpress.org/extend/themes/thematic

  12. momentumkris
    Member
    Posted 1 year ago #

    Hi Dominor,

    I appreciate that. I have contacted the seller. If you wanted to take a stab at it for sh*ts and giggles though, I won't stop you. :)

    I can confirm that it happens in Firefox and Chrome. I'm afraid that I don't know enough to look at the CSS. I might as well read Sophocles in the original Greek. :)

    You can see the problem by following the following link:
    http://www.momentummartialarts.ca/saskmaa/members/

    It's the left seated sidebar menu on that page. It has two main items, Regina, and Saskatoon.

    Not sure how to reproduce the issue. I think it's just a dotted underline that is enabled by default, and I can't find how to disable it.

  13. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    This is the code making that dotted line:

    .widget-area ul li {
        background: url("http://www.momentummartialarts.ca/saskmaa/wp-content/themes/prose/images/sidebar-list.png") no-repeat scroll left top transparent;
        border-bottom: 1px dotted #DDDDDD;

    So add the above to your custom CSS and put a zero in for the border-bottom.

  14. momentumkris
    Member
    Posted 1 year ago #

    Mucho Gracias.

Topic Closed

This topic has been closed to new replies.

About this Topic