WordPress.org

Ready to get started?Download WordPress

Forums

Spun
[resolved] Removing date, time byline from a post (25 posts)

  1. soulluciani01
    Member
    Posted 1 year ago #

    I would like to remove the date, time and byline from my posts and can not seem to figure it out. I have been reading the forum and trying suggestions without any luck.

    I added
    .post-date {
    display: none;
    }

    but it didnt work. Perhaps I added it to the wrong place.. Some clarity would be lovely.

  2. soulluciani01
    Member
    Posted 1 year ago #

    according to this http://"><a href="http://wordpress.org/support/topic/how-to-remove-the-date-time-by-admin-underneath-a-post?replies=5

    I should be able to edit this fairly easy. I have searched and searched and can not find
    .post-date {
    display: none;
    }
    In the css style file. It seems to me that it may need to be edited in the content page. I sure would like some help from one of you super techs out there as I am a novice

  3. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Get the child theme set up first before you do any further modifications to the theme.

  4. soulluciani01
    Member
    Posted 1 year ago #

    Ok. So can you explain to me how to do the aforementioned edit?

  5. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Once you have the child theme set up, post a link to your site and then I'll be able to tell you after seeing the site.

  6. solidgoldextra
    Member
    Posted 1 year ago #

    Hi there. Are you using the default WordPress theme?

    Depending on how the by-line has been implemented in your particular theme, you may need to style ".entry-meta".

    Just as @WPyogi suggested, always setup a child theme before making any changes.

    The WordPress codex has a comprehensive article about child themes. Please digest it first, before making any changes to your theme files: http://codex.wordpress.org/Child_Themes

    For instance, in twentythirteen, you can hide the by-line by adding this CSS style:

    .entry-meta{
    display:none;}

    If you are running WP version 3.6, you can use the "Custom CSS" option in the Appearance section of your Admin Area to make this edit. Saves you having to edit theme files.

    Hope this helps.

  7. soulluciani01
    Member
    Posted 1 year ago #

    I tried this suggestion with no luck. I am using the Spun theme.

    If someone could please explain this I would really appreciate it. been trying to figure out where this is located for 3 days.

    http://Soulluciani.com

  8. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    You don't have a child theme set up...why do you want to make changes that will be lost when the theme is updated?

    I also don't see any pages with dates on them -

  9. soulluciani01
    Member
    Posted 1 year ago #

    This is a test site. For me to learn. Once I understand what I am doing I will put it into place with a child theme ;)

    If you look click the circle images the posts within those have date and byline on them. It looks like this.
    AUGUST 12, 2013 BY SOULLUCIANI
    UNCATEGORIZED
    EDIT

  10. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    I will put it into place with a child theme ;)

    Are you aware that you will need to redo a good amount of the work you are doing to move to a child theme?

    The code you have above is correct - if it's not working, it might be due to some CSS errors:

    http://jigsaw.w3.org/css-validator/validator?uri=http%3A%2F%2Fsoulluciani.com%2F&profile=css3&usermedium=all&warning=1&vextwarning=&lang=en

  11. solidgoldextra
    Member
    Posted 1 year ago #

    I would like to remove the date, time and byline from my posts

    for "Spun" theme.

    I wonder if you managed to get this resolved yet. The code I offered earlier will definitely do the job. I have confirmed this on a fresh copy of the theme.

    If it doesn't work for you, try inspecting the meta content, using chrome developer tools, or firefox firebug. It will show you the exact name of the class, as well as the style rules being applied. If you need to hide it, just add a "display:none".

    As always, use a child theme. Especially if you are just practicing. Makes it easier to roll back, if you break something unintentionally.

    Hope this helps.

  12. soulluciani01
    Member
    Posted 1 year ago #

    So, I deleted and reinstalled in order to work with a child theme. Once I activated the theme it doesnt look right.

    Did I miss a step?
    soulluciani.com

  13. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    You don't have a child theme activated on your site - can you do that? You also have to redo any settings/theme options in a child theme - they aren't all carried over.

  14. soulluciani01
    Member
    Posted 1 year ago #

    Thats what I am working on doing. Basically, I am trying to start from scratch to get a fresh install of the theme, and put the child theme in place. So I deleted wordpress from my host and reinstalled. But when I reinstalled the theme looked this way. Is this correct?

  15. soulluciani01
    Member
    Posted 1 year ago #

    I tried this again. I deleted all the files in my ftp. Then I uninstalled wordpress. Waited and hour, reinstalled wordpress, logged in and reinstalled Spun. I got the same results. Please help.

  16. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    I don't know what you mean by "this way." Looks like a regular Spun theme - if something looks very off to you, try clearing your browser cache. But have you created the child theme? After you create it, you have to activate it. Right now, there is not a child theme active.

  17. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    I got the same results.

    What results? I'm not seeing anything wrong - except that what you have is not a child theme. What do you see that isn't right? Can you take a screen shot and upload it to your site so I can see it?

  18. soulluciani01
    Member
    Posted 1 year ago #

    It was the cache.. thanks. I have put in place a child theme. However, its not looking like the spun theme. You can see what I mean at the site. soulluciani.com

  19. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    This line in your child theme style.css file is not quite right:

    @import url("../spun.css");

    It should be:

    @import url("../spun/style.css");

    After changing that via the Dashboard editor, you need to change to another theme and then back to the child theme. Then make sure your clear your cache again.

  20. soulluciani01
    Member
    Posted 1 year ago #

    This is the code I am using.

    /*
    Theme Name: spun-child
    Theme URI: http: //soulluciani.com/
    Description: This is a custom child theme I have created.
    Author: soul luciani
    Author URI: http: //soulluciani/
    Template: spun
    Version: 0.1
    */

    @import url("../spun.css");

  21. soulluciani01
    Member
    Posted 1 year ago #

    Thanks for the super speedy response. That worked

  22. soulluciani01
    Member
    Posted 1 year ago #

    The code for hiding the byline also worked. Now, I have set my front page to be a static "splash" page. How can I get rid of the credits on the bottom and the menu at the top of the splash page?

  23. soulluciani01
    Member
    Posted 1 year ago #

    I got this error.

    Parse error: syntax error, unexpected T_ENCAPSED_AND_WHITESPACE in /home/content/63/11593663/html/wp-content/themes/spun/footer.php on line 20

    What did I do wrong?

  24. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Did you change something in the parent theme footer.php file? You shouldn't be modifying a parent file - that's the purpose of the child theme.

    You can reinstall the parent theme - just activate twentytwelve, deleted spun parent theme and then reinstall it. Then switch back to your child theme.

    For additional questions, please start a new topic - this thread is about the date/time question.

  25. soulluciani01
    Member
    Posted 1 year ago #

    Ok, Thank you very much. I'm just learning all this stuff so thanks for being patient. I am starting a new thread now.

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic

Tags

No tags yet.