WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Removing date graphic from posts (Mandigo theme) (12 posts)

  1. GMonkey
    Member
    Posted 7 years ago #

    Hi everyone, I've recently started http://www.tipstree.com/ (WIP). As you can see just before the title of each post there is a rectangle displaying the date of the post. I'd like to completely remove that so that no date is displayed. Unfortunatley I'm no good with php and don't know what part of the code I should delete. I'm afraid of messing up the code completely so I'd like to ask the good people here at WordPress forums to help me.

    Any help is greatly appreciated, Thank you.

  2. ccoupe
    Member
    Posted 7 years ago #

    I know this will sound snotty. Pick a another theme that doesn't do that. Or modify the one you have. Or post in the theme problem sub-forum.

    CSS is not my cup of tea, it hurts, perhaps offends my simple mind to look at it. But that's what has to be done. Make backups of your theme files as you modify it one tiny tweak at time.

  3. GMonkey
    Member
    Posted 7 years ago #

    Thanks for the reply ccoupe. Your right, I probably should have posted in the theme sub-forum, sorry about that, I didn't think.

    The Mandigo theme was chosen because of all the customisation options it offered which I found much better than any other theme I've tried, also I think it looks good. Really, changing a theme isn't a good option as I've kinda set my heart on this.

    Is it that big a task to remove the date? Woud anyone else care to take a look?

    Cheers.

  4. GMonkey
    Member
    Posted 7 years ago #

    Anyone else? This topic is still unresolved.

  5. GMonkey
    Member
    Posted 7 years ago #

    I still haven't given up on this. After a little more investigating I found this. Comment 418 is from the creator of the theme, he says

    you can either style the .calborder, .cald, .calm and .cay classes to your taste, or simply remove/replace the whole <div class=”calborder”> block in index.php. It also appears in single.php and archive.php.

    I tried modifying the code myself, removing some lines and experimenting, unfortunatley it broke the design and text was appearing in odd places (and the date still displayed).

    So could someone please take a look and give me some pointers. Thank you.

  6. whooami
    Member
    Posted 7 years ago #

    edit your index.php, etc.. as WAS already stated above.

    Pointers:

    1. I can open your site in my browser, firefox.
    2. I can then view the source of your front page, for example.
    3. When viewing your page source, i can see the following:

    <div class="calborder">
    <div class="cal">
    <span class="cald">21</span>
    <span class="calm">07</span>
    <span class="caly">2007</span>
    </div>
    </div>

    4. Now that I see that the code that is creating the dates is going to be enclosed in those tags, ALL I need to do is LOOK at my theme files.

    5. looking at my theme files, specifically index.php, wow, I see this:

    <div class="calborder">
    <div class="cal">
    <span class="cald<?php echo (get_option('mandigo_dates') ? ' cald2' : '') ?>"><?php the_time((get_option('mandigo_dates') ? 'M' : 'd')) ?></span>
    <span class="calm"><?php the_time((get_option('mandigo_dates') ? 'd' : 'm')) ?></span>
    <span class="caly"><?php the_time('Y') ?></span>
    </div>
    </div>

    There's your pointers - compare what you see in your source to what you see in your files.

    Delete as you see fit.

  7. whooami
    Member
    Posted 7 years ago #

    PS: breaking the style has NOTHING to do with removing the code.. start with removing the stuff inside the span tags..

    If it breaks, it breaks. The fact is that themes are CSS driven and as such, removing something might break the design.

    Thats, pardon the pun, the breaks. Fixing a broken design after you have removed something is another thread.

  8. GMonkey
    Member
    Posted 7 years ago #

    Thanks whooami, it's working now. I did delete that block of code as was stated but I missed out a </div> at the end.

    I did the same on the single.php and archive.php.

    Some pages still showed the date graphics even after I'd deleted that code, but after refreshing the page a few minutes later it went. I'd have thought that the site would update instantly as soon as the code is changed?

    Thanks again.

  9. Chris_K
    Member
    Posted 7 years ago #

    Are you running the wp-cache plugin? That would cause a delay.

    For that matter, most browsers have a cache as well. When making changes in site design, get used to clearing your browser's cache frequently (ctrl-F5 for IE and Firefox is a handy shortcut).

  10. GMonkey
    Member
    Posted 7 years ago #

    Yes I am running wp-cache. Thanks for the tip, good to know for future reference.

  11. Chris_K
    Member
    Posted 7 years ago #

    last tip :-)

    Options -> WP-Cache, Towards the bottom there's a "Delete Cache" button that you can hit to quickly flush the cache when you want to check on changes

  12. uncladchef
    Member
    Posted 6 years ago #

    Here is what I did to get rid of the calender in Mandigo. I deleted this code from index.php, single.php, and archive. php.

    <div class="calborder">
    			        	<div class="cal">
                                                    <span class="cald<?php echo (get_option('mandigo_dates') ? ' cald2' : '') ?>"><?php the_time((get_option('mandigo_dates') ? 'M' : 'd')) ?></span>
                                                    <span class="calm"><?php the_time((get_option('mandigo_dates') ? 'd' : 'm')) ?></span>
                                                    <span class="caly"><?php the_time('Y') ?></span>
                                            </div>

    Done.

Topic Closed

This topic has been closed to new replies.

About this Topic