WordPress.org

Ready to get started?Download WordPress

Forums

SEO Ultimate
[resolved] removing Author in meta property="article:author" (6 posts)

  1. Pierre Fossey
    Member
    Posted 1 year ago #

    Hi, all is in the titleā€¦
    How can i do this ?

    Thanks & well done for the amazing work on this plug-in !!

    http://wordpress.org/extend/plugins/seo-ultimate/

  2. runnerb0y
    Member
    Posted 1 year ago #

    I'm trying to do the same thing. I don't want the 'real' username shown in the source code on pages or on comments. I feel this is a security risk and would love to know how to not allow the user's 'real' login name. Nickname is fine but not real name.

  3. Carl-Joel
    Member
    Posted 1 year ago #

    I would like to see there was options to configure what OG-fields should be applied. The author property is a problem for me in pages and I feel that there shouldn't be an author property for these so I had to manually change this in the source-code which you also can do if you like.

    Go to line ~114 in the file opengraph.php and you should be looking for this line:

    $tags['article:author'] = get_author_posts_url($post->post_author);

    Remove it and the author-og won't be shown anymore.

    In my case I wanted it to show but only on posts, not pages and the solution for me was then:

    if(!is_page()) {
    $tags['article:author'] = get_author_posts_url($post->post_author);
    }

    Remember that when you update the plug-in, the changes you've made will be overwritten.

    Hope this one helps you out Pierre Fossey.

  4. robanna
    Member
    Posted 1 year ago #

    Showing a username in the header sounds like a bad idea to me.

  5. John
    Member
    Plugin Contributor

    Posted 1 year ago #

    The author posts URL (which Open Graph Integrator outputs for the article:author) uses what WordPress calls the user's "nice name." This is something separate from the username, although, in practice, the two are often the same. If you want to change the "nice name" to something else, you can edit the user_nicename field directly in the database.

    The next version of SEO Ultimate will also give you the option of turning off the article:author data altogether.

  6. robanna
    Member
    Posted 1 year ago #

    Seems like an easy fix (or a nice option) would be to use the display_name

    $tags['article:author'] = get_the_author_meta('display_name', $post->post_author);

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic