WordPress.org

Ready to get started?Download WordPress

Forums

Arconix Portfolio
[resolved] Removing "ALL" (6 posts)

  1. Kaouthia
    Member
    Posted 1 year ago #

    Hey there,

    Only just installed the plugin recently and starting to get to grips with it. I've had a read through the docs on the wiki, but I don't seem to be able to find an answer to this.

    Without actually going in and changing the code, is there a way to remove "ALL" from the list of portfolio "Features", and set a default "Feature" for it to go to when the page loads?

    To remove "ALL", I've tried...

    terms="ALL" operator="NOT IN"

    Obviously, didn't work, and I don't have a clue where to begin as to giving it a default feature to highlight on page-load (or if it's even currently possible).

    If neither are currently possible without editing the plugin's code, I would greatly appreciate the addition of both of those features in some future update, as "all" brings up a seemingly random mismatch of images that bear no relation to each other, and I'd rather my viewers go through specific categories, rather than see the whole lot in one lump.

    http://wordpress.org/extend/plugins/arconix-portfolio/

  2. Kaouthia
    Member
    Posted 1 year ago #

    Another issue I've been having...

    If I'm on the default "All" page, or I tell the portfolio plugin to use a single feature of images, when I click on an image, it comes up modal, as expected. If I've not specified a feature, and I click on one of the features to change the image set, the model image display no longer works, and it just links directly to the image (forcing users to click back to get to the portfolio, and it defaulting to "All" again).

    http://www.jbcmedia.co.uk/portfolio/

    Any ideas?

  3. John Gardner
    Member
    Plugin Author

    Posted 1 year ago #

    To answer the first question regarding "all", you have 2 options.
    1. Set your heading parameter in the shortcode to nothing. For example: [portfolio heading=""]
    2. Set the CSS to not display the title: .arconix-portfolio-category-title { display: none; }

    In either case the html will still be output, it will just be held from display. I'll add a check to the heading parameter for the next version that will withhold the html as well when the value is blank.

    The second issue is an interesting one because I don't get that behavior. If I go to your main portfolio page and click on "Animals on location" for example, I get 4 animals. Clicking on an image loads the lightbox. If I then click on "Animals on White" from the horizontal menu I get 2 frog images. Clicking on them still loads them in a lightbox, which is what I would expect. I've tested this on ie9, FF 17.0.1 and Chrome 23.0.1271.97

  4. Kaouthia
    Member
    Posted 1 year ago #

    Thanks John,

    Yup, I've changed it over now so that each category is a separate page using the "feature" tag in the shortcode for each page.

    I've setup another page so you can see the default behaviour I mentioned above.

    http://www.jbcmedia.co.uk/portfolio-default/

  5. John Gardner
    Member
    Plugin Author

    Posted 1 year ago #

    Ah, I gotcha... When the quicksand filter runs to show each category, the callback to the lightbox (in your case fancybox) script is flushed and would have to be re-called.

    Copy portfolio.js from includes/js/ in my plugin to the root of your theme's folder and rename the file to arconix-portfolio.js. Go into that file and you'll see a commented out section towards the bottom that says "Initalize our PrettyPhoto Script When Filtered". Uncomment the code below that and replace lightbox(); with ("a.zoom").fancybox();

    That should get it working again.

  6. Kaouthia
    Member
    Posted 1 year ago #

    Fantastic, thanks John. Will give that a go. :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.