WordPress.org

Ready to get started?Download WordPress

Forums

Edit Flow
[resolved] Remove yourself from notifications (10 posts)

  1. annlickander
    Member
    Posted 1 year ago #

    Hi!

    I don't seem to be able to remove myself from the notifications if I'm the author of the page.
    It would be lovely if there was a way, even though I'm the author, to be able to disable the notifications.

    http://wordpress.org/extend/plugins/edit-flow/

  2. cojennin
    Member
    Plugin Author

    Posted 1 year ago #

    When you save a post for the first time, do you see a checkbox next to your user name in the notifications box (the box called "Notifications," usually below the post content area?

    When you uncheck that, do you still get notifications?

  3. annlickander
    Member
    Posted 1 year ago #

    Yes, I can see the checkbox.
    Before I've saved the new post/page, the checkbox next to my username is unchecked. But as soon as I've published the post/page it's checked. I've tried to uncheck it, and save the post/page but I still get notifications and if I edit the post/page I can see that the checkbox is still checked.

  4. cojennin
    Member
    Plugin Author

    Posted 1 year ago #

    I've created a GitHub issue for this. Feel free to follow it. If you find any other issues related to this one, you can post them here or on GitHub. In the meantime I'll see if I can unearth any other bugs related to this issue and start working on a fix.

  5. Daniel Bachhuber
    Hand Built
    Plugin Author

    Posted 1 year ago #

    This is actually the default behavior for Edit Flow. Here are details on how to disable.

  6. annlickander
    Member
    Posted 1 year ago #

    Thank you comradefuzz, I will follow your Github issue :)

    Daniel Bachhuber, I'm aware that's the default behaviour. And, I like it, most of the time. But once in a while I find myself, or some of my co-writers, to be an author of a post/page but not wanting to be subscribed.

  7. Daniel Bachhuber
    Hand Built
    Plugin Author

    Posted 1 year ago #

    But once in a while I find myself, or some of my co-writers, to be an author of a post/page but not wanting to be subscribed.

    Right. You can use the code snippet to disable the behavior. There isn't a away to have you auto-subscribed sometimes but not all the time.

  8. annlickander
    Member
    Posted 1 year ago #

    Alright, maybe in the future then :) Thank you for your fast replies!

  9. ebedgert
    Member
    Posted 1 year ago #

    I tried using this code in functions.php but it is still auto-adding the author to the notifications list. The behavior hasn't changed at all.

    Hopefully you will make it clearer in the documentation that this is the default behavior, because a lot of people seem surprised it does this. Or, in a future version, have an option to turn this off. (I work in a large organization where authors really aren't part of the editorial process, they just submit stuff and don't need to see notifications of every change to their material.)

  10. ebedgert
    Member
    Posted 1 year ago #

    An update on this code snippet: It only seems to work when you are creating a post. If you create a post, it won't auto-add anyone, which is great.

    However, once you change a post's status, people (including the author) get auto-added again, which sort of defeats the purpose I think. Is there any way to alter the code snippet to make sure that changing a post's status won't make the unwanted auto-subscribe behavior recur?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic