WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] remove "You may use these HTML tags and attributes: " (19 posts)

  1. bwoose
    Member
    Posted 3 years ago #

    Hi. I'm new to wordpress. After struggling with Joomla for two years, I've found wordpress light and very easy to use. I am however, banging my head against a brick wall over this problem and google isn't bringing anything up on the subject.

    At the bottom of a page or post, there's a option for people to leave a reply to the post. It includes:

    You may use these HTML tags and attributes: a href="" title="" abbr title="" acronym title="" b blockquote cite="" cite code del datetime="" em i q cite="" strike strong - i removed the brackets because it was messing up the thread.

    I suspect my customers won't understand this or want to include it in any response but I can't find the css or php file that includes this. Can anyone help?

    http://weddingphotographersinsheffield.com/?p=5

    arras theme http://demo.arrastheme.com/

    WordPress v3.0

    Cheers.

  2. lockettpots
    Member
    Posted 3 years ago #

    You can add this to the bottom of your css file

    .form-allowed-tags{
    display:none;
    }

    I think that should do it

  3. bwoose
    Member
    Posted 3 years ago #

    sorry - i did see that fix in another forum. I looked through the code and saw that is also used another css file:
    @import url('css/default.css');
    but that file doesn't exist.

    All very strange.

  4. lockettpots
    Member
    Posted 3 years ago #

    Just go to your wp-admin page Appearance -> Editor.

    On the right hand side you should see some stylesheets listed under the heading of Styles choose one of those and edit it as in the previous post

  5. elie-palima
    Member
    Posted 3 years ago #

    hello bwoose... do you know how to use ftp? is so, then do this...

    1. connect via ftp and open the 'pilcrow' folder... here's the exact location: public_html/wp-content/themes/pilcrow/

    2. when you reach that folder, Look for the file named 'style.css' right click, and hit edit via notepad...

    3. once you've opened it on notepad, hit ctrl+f and search for this exact words: ".form-allowed-tags" (without the quotes)

    you should be able to see something simmilar to this:

    .form-allowed-tags {
    	color: #999;
    	font-size: 12px;

    4. under that code,(right after font-size:12px;) Paste this stuff:

    display:none;

    5. hit save and you shouldn't be able to see those stuffs anymore! :-)

    However,

    if you can access your stylesheet (style.css) via wp-admin>>appearance>>> editor, then just do what lockettpots suggested...

    open style.css on admin>appearance>>editor and do what I suggested from step 3 to 5! only this time, you won't be editing the stylesheet on notepad but directly on the wp admin panel.

    hope this helps!

    elie

  6. bwoose
    Member
    Posted 3 years ago #

    style.css

    [CSS moderated as per the Forum Rules. Please just post a link to your site.]

    that's it. I checked in css/default.css and user.css but nothing doing either. I've left a thread in the arras forum. but this is a common feature of wordpress and i'm stunned that someone felt the need to include it let alone omit the option to remove it when everything else is put together so well.

  7. alchymyth
    The Sweeper & Moderator
    Posted 3 years ago #

    to add to the confusion:
    http://codex.wordpress.org/Function_Reference/comment_form

    the allowed html tag list (with the corresponding css class) comes directly from the comment_form() code.
    if you can find where the comment_form() is called (probably comments.php), you can change it there to remove the 'comment_notes_after'.

    there is no need for the theme to have this class anywhere in the css files.
    if you want to use it, add it to the usual css file - in arras this is user.css.

  8. bwoose
    Member
    Posted 3 years ago #

    i just added ,'comment_notes_after' => '' to comments.php but it removed the whole reply function. I just want to remove the text.

  9. alchymyth
    The Sweeper & Moderator
    Posted 3 years ago #

    you can add it as the last 'parameter' into comment_form() in comments.php:

    http://pastebin.com/uDPZzQtg

  10. bwoose
    Member
    Posted 3 years ago #

    sorted it - added

    .form-allowed-tags { display: none; }

    into user.css and it worked a treat.

  11. Spencer Hill
    Member
    Posted 3 years ago #

    Be sure to mark this as resolved then. Enjoy!

  12. Mark Choo
    Member
    Posted 2 years ago #

    @ lockettpots - Thank you! After an hour of research I finally found this post, added the code below to my style.css file and it work great!

    .form-allowed-tags{
    display:none;
    }

  13. Tagcloud
    Member
    Posted 2 years ago #

    That work fine @Mark Choo, thanks

    Just added the code in the section for comments in style.css

  14. Mark Choo
    Member
    Posted 2 years ago #

    Rondena - You are very welcome my friend! Happy to give back to the community!

    Mark

  15. jsolorzanoarts
    Member
    Posted 2 years ago #

    This helped me too! The last thing I want to do is mess with any php files that will cause havoc on my site. This is the simplest solution, and I like simple! Thanks @lockettpots @mark Choo!

    And thanks for posting this @bwoose - I felt your frustration today, but also found the solution here.

  16. michael.motokaku
    Member
    Posted 2 years ago #

    wow! bwoose...

    thanks a lot. it worked for me.

    http://studentemploymentcenter.com/

  17. msheaver
    Member
    Posted 2 years ago #

    It appears that the current version of WP (3.3.1) is no longer assigning the class form-allowed-tags to the <p> that contains the tag code, so this CSS cannot be applied. Any ideas of where I can look?

  18. alchymyth
    The Sweeper & Moderator
    Posted 2 years ago #

    @msheaver

    look into comments.php, for the comment_form() code;

    then apply this edit:
    <?php comment_form(array('comment_notes_after' => '')); ?>

    http://codex.wordpress.org/Function_Reference/comment_form

    or use a tool such as Firebug http://getfirebug.com/ to identify the css of this text;

    or post a link to your site.

  19. naturegirl321
    Member
    Posted 2 years ago #

    I'm using a Thematic child theme. Code is

    <div id="form-allowed-tags" class="form-section">
    <p><span><?php _e('You may use these <abbr title="HyperText Markup Language">HTML</abbr> tags and attributes:', 'thematic') ?></span> <?php echo allowed_tags(); ?></p></div>
    <?php comment_form(array('comment_notes_after' => '')); ?>

    But
    You may use these HTML tags and attributes: <abbr title=""> <acronym title=""> <b>

    <cite> <del datetime=""> <i> <q cite=""> <strike>

    still appears. What am I doing wrong?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.