WordPress.org

Ready to get started?Download WordPress

Forums

Pilcrow
[resolved] Remove unwanted comments on home page. (6 posts)

  1. Terry
    Member
    Posted 8 months ago #

    I have made my home page STATIC, but comments are showing up. I have 3000 now. How can I delete these? When I use the drop down box and try to select "999", I get this response when I try to "move to spam".

    Request-URI Too Large

    Thank you in advance for any help!

  2. Koliu
    Member
    Posted 8 months ago #

    This plugin may help, although I didn't tested it. Another way you can do that is via SQL query.

  3. Hi there, there are a few options.

    - you could remove the comments in batches
    - you could remove the comments directly in the database as Koliu suggested, but I'd only recommend that if you've made a backup of your database first and are comfortable with MySQL commands
    - you could leave the comments but hide them on the front end (public side) with CSS
    - you could try a bulk-comment removal plugin, like the one Koliu suggested. I can't recommend a specific one since I haven't used any myself.

    Let me know how it goes!

  4. p.s. if you really have 3000 spam comments that weren't detected as such, I strongly suggest you install a good anti-spam plugin like Akismet.

  5. Terry
    Member
    Posted 8 months ago #

    Hello Kathryn

    THank you. I ended up deleting them in batched of 200. I had not activated the Akismet.

    Thanks.

  6. Great, glad you're all sorted.

Reply

You must log in to post.

About this Theme

About this Topic