WordPress.org

Ready to get started?Download WordPress

Forums

Easy FancyBox
[resolved] Remove the "DASH" at the beginning of each image/box (8 posts)

  1. adguy31
    Member
    Posted 1 year ago #

    Hey,

    I don't know what else to call this but if you look at any image inserted into my posts there is annoying "Dash/Hyphen" at the far left of the image and I have no idea why this is there or how to remove it.

    Please look at any image on my blog posts and you will see it. http://sethancock.com/blog

    Any advice on how to remove this would be greatly appreciated.

    Thanks,
    Seth

    http://wordpress.org/extend/plugins/easy-fancybox/

  2. RavanH
    Member
    Plugin Author

    Posted 1 year ago #

    Why would you think it's coming from my plugin? The hyphen is defined in your themes stylesheet... Just look for .wp-caption-text in there.

    By the way, if you want to use FancyBox, you'll need to:
    1. remove the ShadowBox plugin;
    2. switch to another Google Analytics plugin (like Google Analyticator) because the one from Yoast adds onclick attributes to all links for click tracking which breaks FancyBox...

  3. RavanH
    Member
    Plugin Author

    Posted 1 year ago #

    To be more precise about the CSS rule in your themes style.css:

    .wp-caption .wp-caption-text:before {
    ...
    	content: '\2014';
    ...
    }

    That's the hyphen.

  4. adguy31
    Member
    Posted 1 year ago #

    I think it's coming from your plugin or Shadowbox because I just switched themes and it's still there. Check out my old blog at blog.sethhancock.com and you will see the consistency.

    Thanks for the advice on switching everything. I will look into that now.

    I appreciate the timely response.

    Seth

  5. adguy31
    Member
    Posted 1 year ago #

    Never mind. I forgot I switched themes on all the blogs so I can't show you the previous version. I will look for that code and make the changes to the respective plugins.

    Seth

  6. adguy31
    Member
    Posted 1 year ago #

    Cool! Thanks for the advice. I changed the "Before" to "None" and it got rid of the dash. THANK YOU for telling me where to look. I really appreciate it and your timely response.

    Seth

  7. RavanH
    Member
    Plugin Author

    Posted 1 year ago #

    Then that other theme must have a similar style rule. My plugin does not modify any post content. It just kicks in when an image link is clicked...

    Like I said, it's that line content: '\2014'; in the file /wp-content/themes/ravage/style.css ... just remove that line and it should be solved.

  8. RavanH
    Member
    Plugin Author

    Posted 1 year ago #

    I changed the "Before" to "None"

    Better to leave that :before in place. Just remove the line

    content: '\2014';

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.