WordPress.org

Ready to get started?Download WordPress

Forums

nrelate Related Content
Remove specific pages/post and widget not working (7 posts)

  1. Willem-Siebe
    Member
    Posted 1 year ago #

    Hi,

    I was wondering if I can exclude specific pages/posts (like sitemap) from showing up as related content.

    Also, there is a widget available but this is not showing me anything. In backend it gives me a link to change settings, but on that backend page from nrelate I can do nothing...

    Kind regards,

    Willem

    http://wordpress.org/extend/plugins/nrelate-related-content/

  2. @siebje -- You can exclude specific posts from showing as related content suggestions by going to the nRelate Dashboard page > Exclude Categories. Here's a screenshot for reference: https://www.dropbox.com/s/pwbzbo8f9qpvpgb/Screen%20Shot%202012-10-04%20at%203.34.25%20PM.png

    Unfortunately there's no way to exclude specific pages from showing up as related recommendations without excluding all pages as a whole. This is a good feature to have though, and one we are thinking about including in an upcoming build of our plugin.

  3. Willem-Siebe
    Member
    Posted 1 year ago #

    Hi, definitly +1 to have that included :-).
    Thanks for your reply.

  4. Cathedral City Guide
    Member
    Posted 7 months ago #

    @katrina - I think this would be a useful feature too. How about giving us the option to exclude pieces of content based on a tag or a custom field rather than a category? This would then be applicable to both posts and pages.

    Just a thought, love nrelate by the way.

  5. katrina@nrelate
    nrelate Support Rep
    Posted 7 months ago #

    @cathedralcityguide -- Thanks for the idea regarding how to exclude posts. I'll forward this over to tech team to see if this is possible for a future build of our plugin.

    - Katrina @ nRelate

  6. kyleherranen
    Member
    Posted 5 months ago #

    Just thought I'd drop a line seeing as though this thread is somewhat new.

    I had the same problem concerning POSTS. There were a few posts in a category that I wanted to exclude. I FOUND A WORK AROUND!

    To exclude individual posts in a particular category you first need to create a new "dummy" or empty category and call it something you will remember. I called my newly created category "nrelate exclude". Now, go to your nrelate dashboard and click the check box to exclude the category "rnrelate exclude" under Exclude Catergories. Now you can go to the posts you'd like to exclude and add them to the "nrelate exclude" category, so now they are associated with two categories but one is being excluded.

    This works because of the way nrelate caches the pages. It clearly says that if a post belongs to two categories and one of those categories is being excluded, that post will not be included ANYWHERE!

    Hope this helps. It did for me!
    Kyle

  7. katrina@nrelate
    nrelate Support Rep
    Posted 4 months ago #

    @kyleherranen -- Thanks, Kyle. The info you gave is definitely helpful and could help some of our other users facing the same issue. We appreciate it!

    - Katrina @ nRelate

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.