WordPress.org

Ready to get started?Download WordPress

Forums

Lightbox Plus ColorBox
[resolved] Remove scrollbars in iFrames (again) (4 posts)

  1. J Grandin
    Member
    Posted 1 year ago #

    Hi everyone,

    The plugin works perfectly well on a website project where a iframe lightbox opens an inner page with a flipbook in javascript. Have a look here then click on 'Blue Sailor's' in the right column.
    I use Lightbox Plus 2.4.6.

    The annoying thing are the scrollbars I would like to remove, because they become crazy with the javascript flipbook effect.

    I tried the solution in this topic (1 year ago):
    #cboxLoadedContent {overflow: hidden !important;} doesn't work anymore but iframe.cboxIframe {overflow: hidden !important;} does. But ONLY on Firefox, not in Chrome, Safari and IE9.

    The solution I also found is to add the attribute scrolling='no' in the <iframe> tag. I hope this should work for all the browsers (it does on Chrome).
    But it's tricky to enable this attribute since I don't know how the iframes are generated by the plugin.

    I eventually found a solution in that topic (3 years ago):

    Add a new line 165 in lightbox.php as follows $lightboxPlusJavaScript .= ' $lbp.fn.colorbox.settings.scrollbars = false;'.$this->EOL( );

    But the plugin evolved so much that even the lightbox.php doesn't exist anymore. The code have moved to the lightbox-plus/classes/actions.class.php file, but I was not able to add a javascript line that works.

    Finally I found this in the plugin changelog for the version 1.6:

    Added scrollbars option to allow users to turn off scrollbars when using the resize() method.

    It seems that this option doesn't exist anymore.

    Did somebody encounter the same problem and found a solution to disable scrollbars? Is there a way to disable scrollbars on the Lightbox Plus options panel?

    Thank you by advance for your kind help.

  2. zouper
    Member
    Posted 1 year ago #

    I see you solved the issue, as I see no scrolling. I have an issue with inline boxes that load a gravity form within. If the size of the browser window is smaller I get annoying scrollbars. How did you finally get rid of them?

    Thanks

  3. Dan Zappone
    Member
    Plugin Author

    Posted 1 year ago #

    Sorry about the delay. Paying work takes place over free. Somewhere along the way I accidentally removed the feature.

    Let me see what can be done about that sizing though. Hopefully sooner this time.

  4. J Grandin
    Member
    Posted 1 year ago #

    Dear zouper,
    Thanks to my customer, the solution was to remove the flipbook he doesn't like at the end.
    The only solution I found was to change the javascript generated by the plugin by adding the parameter "scrolling='no'" somewhere. I tried hard during half a day, by modifying the php page where the js scripts are generated, then I gave up since I'm afraid I'm not a js wizard.

    Thanks also to Dan Zappone for the plugin, the answer and for taking care of the issue :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic