WordPress.org

Ready to get started?Download WordPress

Forums

Easy FancyBox
[resolved] Remove Scroll Bars Version 1.3.4.9 (29 posts)

  1. Mark Shirley
    Member
    Posted 1 year ago #

    version Version 1.3.4.9
    Can anyone point me to the option to remove the scroll bars

    http://wordpress.org/extend/plugins/easy-fancybox/

  2. brycerafflesound
    Member
    Posted 1 year ago #

    Same question. Same version. Would like to remove scroll bars.

    I read somewhere in the forums that {scrolling:no} might work:

    <a class="fancybox-iframe{scrolling:no}" href="http://www.brycerafflesound.com/contactform/"><img src="http://brycerafflesound.com/images/Contact-b.png" width="40" height="140" /></a>
    ...but that just causes the fancybox to stop working entirely so the link would open as a separate page instead of as a fancybox.

    I posted on google groups and RavanH was kind enough to redirect me here. He also suggested I try using inline content mode instead of iframe mode (was trying to remove scrollbars from a contact form in a pop-up iframe). When I tried that, my content became invisible, so not sure where I went wrong there.

    Still hoping for a solution for removing scrollbars - I'm open to using inline content instead if A) scrollbars won't be an issue and B) someone can help me to get the content to actually display. I copy-pasted the exact code from the FAQ.

  3. RavanH
    Member
    Plugin Author

    Posted 1 year ago #

    For metadata to work you need a space between the class name and the metadata like so:

    class="fancybox-iframe {scrolling:no}"

    But you might be better off installing the 1.5 development version http://downloads.wordpress.org/plugin/easy-fancybox.zip which features options on the settings page to disable scrolling :)

  4. Mark Shirley
    Member
    Posted 1 year ago #

    Didn't do it for me - unfortunately I cant make the latest dev version to work in twenty-eleven

  5. RavanH
    Member
    Plugin Author

    Posted 1 year ago #

    unfortunately I cant make the latest dev version to work in twenty-eleven

    Strange. I'm using Twenty Eleven (or child themes thereof) on many of my sites and it works just fine. Do you have a link where I can see it not working?

  6. Mark Shirley
    Member
    Posted 1 year ago #

    Hi there I've just re-installed the dev version on my twenty-eleven child theme

    http://www.ricecreative.co.uk/willisnursing

  7. RavanH
    Member
    Plugin Author

    Posted 1 year ago #

    For some reason the jQuery library is loading on the footer, which is too late and causes errors... Are there any other plugins active?

  8. Mark Shirley
    Member
    Posted 1 year ago #

    Akismet and timthumb vunerability acanner but ive now deactivated them and recahed my browser still doesnt work

  9. RavanH
    Member
    Plugin Author

    Posted 1 year ago #

    UPDATE: could you try the new dev version 1.5.0dev7 from http://downloads.wordpress.org/plugin/easy-fancybox.zip ?

  10. Mark Shirley
    Member
    Posted 1 year ago #

    Yeah - thanks just tried it, unfortunately it doesnt work with twentyeleven.

  11. RavanH
    Member
    Plugin Author

    Posted 1 year ago #

    Was that version dev7 or dev6 you tried last? Looks like you switched back again so I cannot see what's still going wrong...

  12. Mark Shirley
    Member
    Posted 1 year ago #

    Sorry ill reinstall it again from your link
    http://www.ricecreative.co.uk/willisnursing

    ive installed version 1.5.0dev7

  13. RavanH
    Member
    Plugin Author

    Posted 1 year ago #

    You are sure it says "version 1.5.0dev7" on the plugins page?

  14. RavanH
    Member
    Plugin Author

    Posted 1 year ago #

    Hang on... think I found it. Working on a new dev version right now...

  15. Mark Shirley
    Member
    Posted 1 year ago #

    Yeah its 1.5.0dev7 ill leave it in

  16. brycerafflesound
    Member
    Posted 1 year ago #

    The dev version doesn't work for me either. None of my links open in fancybox any more.

  17. Mark Shirley
    Member
    Posted 1 year ago #

    Hi brycerafflesound

    RavanH is looking at it now for us.

  18. RavanH
    Member
    Plugin Author

    Posted 1 year ago #

    @ravalde a new version .dev10 is uploading now... wait 15 minutes before downloading a new zip from http://downloads.wordpress.org/plugin/easy-fancybox.zip then try it :)

    @brycerafflesound I don't know if you are facing the same issue or not. In any case, try the latest dev version and if it still does not work, please share a link :)

  19. Mark Shirley
    Member
    Posted 1 year ago #

    Thanks Rolf

    I'll give it a go and post back :-)

  20. Mark Shirley
    Member
    Posted 1 year ago #

    Version 1.5.0dev10 is installed and seems to work fine. I't seems to have solved the iframe reload problem (Hurrah). But I still dont seem to be able to get rid of the scroll bars. I tried setting (Scrolling "Never" Define scrolling and scrollbar visibility.) But hey it's sure nice to have the iframes reloading - Thanks for your help - top man :-)

  21. RavanH
    Member
    Plugin Author

    Posted 1 year ago #

    Mark, use class="fancybox-inline" (instead of just fancybox) for all inline content links from now on... Unless you switch back to an older version ;)

  22. Mark Shirley
    Member
    Posted 1 year ago #

    HURRAH - Huston we have touch down - it works no scroll bars and iframe reload works - Thanks Rolf :-)

    SEE MAP ZONES
    http://www.ricecreative.co.uk/willisnursing/

    <a href="#north-west" class="fancybox-inline">North West/a>
    <div style="display:none" class="fancybox-hidden">
            <div id="north-west">
    
    <iframe width="300" height="300" frameborder="0" scrolling="no" marginheight="0" marginwidth="0" src="https://maps.google.co.uk/maps?f=q&source=s_q&hl=en&geocode=&q=61+Hamilton+Square+Hamilton+Court+Birkenhead+Wirral+CH41+5AT&aq=&sll=53.650636,-2.994261&sspn=0.020425,0.055747&ie=UTF8&hq=61+Hamilton+Square+Hamilton+Court+Birkenhead+Wirral+CH41+5AT&t=m&ll=53.394769,-3.017035&spn=0.007677,0.012832&z=15&iwloc=A&output=embed&iwloc=near"></iframe><br /><small><a href="https://maps.google.co.uk/maps?f=q&source=embed&hl=en&geocode=&q=61+Hamilton+Square+Hamilton+Court+Birkenhead+Wirral+CH41+5AT&aq=&sll=53.650636,-2.994261&sspn=0.020425,0.055747&ie=UTF8&hq=61+Hamilton+Square+Hamilton+Court+Birkenhead+Wirral+CH41+5AT&t=m&ll=53.394769,-3.017035&spn=0.007677,0.012832&z=15&iwloc=A" style="color:#0000FF;text-align:left">View Larger Map</a></small>
    
    <div id="fancy-header">North West:</div>
    61 Hamilton Square
    Hamilton Court
    Birkenhead
    Wirral
    CH41 5AT
    Tel: 0151 245 0224
    <a href="mailto:northwest@willisnursing.co.uk">northwest@willisnursing.co.uk</a>
    <a href="http://www.ricecreative.co.uk/willisnursing/north-west/"><strong>Click here for more information</strong></a>
    </div><!--End of north west-->
    </div><!--End of north west href-->
  23. Mark Shirley
    Member
    Posted 1 year ago #

    opps

    close the

    <a href="#north-west" class="fancybox-inline">North West</a>
  24. brycerafflesound
    Member
    Posted 1 year ago #

    Hi RavanH.

    I installed the latest development version and am still having the same issue. I don't think my issue is exactly the same as Mark's - initially the issue was that I couldn't disable scrollbars. Now that I've installed the latest development version my fancybox links are no longer opening as a fancybox.

    http://www.brycerafflesound.com/portfolio/

    Click on basically any of the images to see what I'm talking about. The floating contact button image is the one that I was trying to fix.

  25. RavanH
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Bryce, the dev version needs jQuery 1.7 or higher (1.8 is included in WordPress) but something (a plugin or your theme) is forcing your site to use jQuery 1.5 hosted by Google. Any plugin active that might be doing this?

  26. brycerafflesound
    Member
    Posted 1 year ago #

    I guess that explains it.

    um, possibly, I'm using a bunch of plugins + a custom theme (Metropolis) from Themeforest

    Akismet, Easy Fancybox, Flexo Archives, qTranslate, WP Twitter Timeline, and WP Float

    Do you know how I might be able to figure out which one is causing the conflict and how I might fix that?

  27. RavanH
    Member
    Plugin Author

    Posted 1 year ago #

    Looking closer I suspect it's your theme... Look inside functions.php to find this URL:
    https://ajax.googleapis.com/ajax/libs/jquery/1.5/jquery.min.js
    If it's there, simply change it to:
    https://ajax.googleapis.com/ajax/libs/jquery/1.8/jquery.min.js

    But that will not be enough because upgrading the jQuery library will cause an error in a theme script file (that's why I suspect it's the theme) which you can solve by editing the theme file js/vt.js. Find near the end of the file the part that starts with
    // pf
    and ends with
    // end pf
    and completely remove that part (it's related to prettyPhoto which you're not using anymore anyway)...

  28. brycerafflesound
    Member
    Posted 1 year ago #

    Thanks so much! It's working now. So happy. :)

  29. Mark Shirley
    Member
    Posted 1 year ago #

    That's what makes wordpress a joy to work on people like Rolf make it tick - Thanks again

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic