WordPress.org

Ready to get started?Download WordPress

Forums

WordPress Related Posts
[resolved] remove pin button from related posts (10 posts)

  1. jmckiernan86
    Member
    Posted 10 months ago #

    I just added a mouseover pinterest button to all of the images on my site, only I don't want them showing on the related posts like they are now - example - http://supplementhelper.com/how-to-create-a-no-bs-ultra-clean-super-cheap-muscle-building-supplement-stack/.

    how would I assign assign “nopin” class to the related posts?

    Thanks

    http://wordpress.org/extend/plugins/wordpress-23-related-posts-plugin/

  2. silvoslaf
    Member
    Plugin Author

    Posted 9 months ago #

    Hey, I'm not 100% sure, but I think some of our users already dealt with this problem in this thread: http://wordpress.org/support/topic/pin-it-button-showing-on-related-post-how-do-i-turn-off?replies=4

    Did this help?

    Let me know, I'm eager to find out!

    Take care & have a nice day!

    Best,
    Silvo

  3. jmckiernan86
    Member
    Posted 9 months ago #

    Thanks for the reply. The answer on that thread was to make changes to the wp-related posts plugin files right? Won't those changes be overridden in the next update. Also I'm note sure exactly what changes need to be made. That answer was a little confusing to me.

    Thanks

  4. silvoslaf
    Member
    Plugin Author

    Posted 9 months ago #

    Hey, no problem, I'll gladly elaborate!

    Since you'll be making these changes in your theme editor (under the tab 'Appearance'-'Editor'), those won't be overridden after you'll update our plugin.

    First, go to your plugin settings and un-tick the box next to "Auto Insert Related Posts". After that, go under the tab 'Appearance'-'Editor', select your theme and click on the single.php file to make the changes described below:

    <?php the_content(); ?>
    <span class="nopin"><?php wp_related_posts()?></span>

    Enter that code after your post content, click the 'Save' button and you're done! Let me know how it goes or if you have any more questions — I'm here to help!

    Take care & have a nice day!

    Best,
    Silvo

  5. jmckiernan86
    Member
    Posted 9 months ago #

    that makes sense the only problem is my theme (headway) doesn't have a single.php file - it only includes header.php, footer.php, functions.php and index.php. any ideas?

    Thanks again for you help!

  6. jmckiernan86
    Member
    Posted 9 months ago #

    okay I figured it out. With headway you have to do it a little differently. Thanks!

  7. silvoslaf
    Member
    Plugin Author

    Posted 9 months ago #

    Hey, glad to hear that, really!

    What was the file called? Kinda curious, since it's good to know these kind of things if someone else has any similar problems. :)

    Thanks & take care!

    Silvo

  8. jmckiernan86
    Member
    Posted 9 months ago #

    With the Headway base theme they have it set up so that instead of using the normal wordpress php files you customize the pages using a grid system. So in this case the workaround was to add a "custom code block" grid block and add the <?php wp_related_posts()?> in that. I didn't even need to use the <span class="nopin"> anymore because its a separate block (directly under the content block) which is not part of the page content so the pinit button did not show up. sounds a little confusing but anyone who is using headway should be able to make sense of it :)

  9. silvoslaf
    Member
    Plugin Author

    Posted 9 months ago #

    Cool, I can somehow see how this workaround is functioning. Big thanks for this update, we truly appreciate it! :)

    As always — if you have any questions or if you stumble upon any problems (let's hope not, though!), do not hesitate to let me know! I'll gladly help!

    Take care & have a nice day!

    Silvo

  10. jmckiernan86
    Member
    Posted 9 months ago #

    Great, thank you again for your help!

Reply

You must log in to post.

About this Plugin

About this Topic