WordPress.org

Ready to get started?Download WordPress

Forums

remove off-white frame from images (6 posts)

  1. LailaArad
    Member
    Posted 2 years ago #

    I'm using the Weaver II theme.
    All pictures/images I insert into my site pages have a frame which I would like to remove. See example the flag image here:

    How do I remove the frame around images?

    I tried looking for it in the style sheet but could not find the right place to change the code.

  2. peter achutha
    Member
    Posted 2 years ago #

    Try this:-

    1. Edit your post

    2. Click on the picture and Edit Image

    3. Delete any thing in Caption field - even blank or space characters

    4. Select 'Advance Image Settings' and set 'Horizontal space' and 'Vertical space' to 0.

  3. ClaytonJames
    Member
    Posted 2 years ago #

    Try this: Go to the the Advanced Options tab of the Weaver II WordPress theme admin panel, and add this to your custom CSS rules and save the changes.

    #content .wp-caption img,
    #content img.size-thumbnail,
    #content img.size-medium,
    #content img.size-large,
    #content img.size-full,
    #content img.attachment-thumbnail {
    	/*-webkit-box-shadow:0 1px 2px #bbb;
    	-moz-box-shadow:0 1px 2px #bbb;
    	box-shadow:0 1px 2px #bbb;*/
    }

    I think that should comment out/remove the shadows you are seeing around the images.

  4. LailaArad
    Member
    Posted 2 years ago #

    None of the 2 options above helped. I still get the very light frame around my pictures. Maybe you didn't quite understand how it looks?

    Go to http://www.telavivgreeter.com and you can see it on the home page - the 3 images (green boxes) all have the light frame. Also all the photos on the site have them.

    What's strange is that the logo on the right (widget) doesn't have that frame.

    Also the flag in the about page doesn't have it. It did have it when the flag was bigger, but when I reduced its size the frame disappeared.

    Strange yeah?

  5. ClaytonJames
    Member
    Posted 2 years ago #

    I saw the images you are concerned with, and "#content .wp-caption img,..." is what is causing the issue. Specifically, what I posted above. :-)

    After you make the entry to your custom style sheet and save the changes, you may need to log out and clear your browser cache completely in order to see the changes. Your browser caches the style sheet, and may not show the update until refreshed. Ctrl+F5 might do the same thing, without having to clear the cache manually.

    If you don't have any luck using the custom css feature of the theme, as a last resort you could edit the actual weaver II style sheet. (although you should not have to with that theme)

    You will find this on lines 1625-1634 in the style sheet

    #content .wp-caption img,
    #content img.size-thumbnail,
    #content img.size-medium,
    #content img.size-large,
    #content img.size-full,
    #content img.attachment-thumbnail {
    	-webkit-box-shadow:0 1px 2px #bbb;
    	-moz-box-shadow:0 1px 2px #bbb;
    	box-shadow:0 1px 2px #bbb;
    }

    Try changing it to the exact code I posted previously. The code has the comments that remove the shadows. "/* */"

    I tried it in firebug and it worked as expected.

    Good luck!

  6. LailaArad
    Member
    Posted 2 years ago #

    thanks. I will try it.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.