WordPress.org

Ready to get started?Download WordPress

Forums

AlbinoMouse
[resolved] Remove Mobile code (12 posts)

  1. webdirr
    Member
    Posted 1 year ago #

    Hi.
    Want to have same layout on the website on the phone as it is at the web in the computer.

    How do I turn off that mobile template?
    Want to have the original template on phones too =)

  2. pixelstrolch
    Member
    Theme Author

    Posted 1 year ago #

    Hi webdirr
    AlbinoMouse is responsive and doesn't have desktop and mobile template files.
    The responsive styles are all at the end in the style.css stylesheet.

  3. webdirr
    Member
    Posted 1 year ago #

    Ok. thx.
    do you know which one of the code to remove.
    tried like 6hours yesterday without any luck. :(

    would estimated it =)

  4. Andrew
    Forum Moderator
    Posted 1 year ago #

    Download and install this Custom CSS Manager plugin and enter this in its allocated section of the dashboard;

    @media only screen and (max-width: 970px) {
     #header-searchform {
      width: auto;
     }
    }
    
    @media only screen and (max-width: 480px) {
     .social-buttons > div,
     #footer1,
     #footer2,
     #footer3,
     #footer4 {
      width: auto;
     }
    }
    
    .container {
     min-width: initial;
     max-width: initial;
     width: 960px;
    }
    
    .sidebar-right #content {
     width: 600px;
     min-width: initial;
    }

    That should take care of the basic formatting styles involved in the mobile theme, but there are other text styles too.

    Look at the very bottom of their stylesheet, look for the section "@media only screen and (max-width: 480px)". Everything inside there not already overridden should be something you need to override.

    Simply removing that section in the theme's style.css file will only be temporary until the theme updates. When the theme updates, your changes will erase.

    The Custom CSS Manager plugin should evade this. Alternatively use a Child Theme.

  5. webdirr
    Member
    Posted 1 year ago #

    Or can I stay with the mobile css style.
    cause the problem with the site on the mobilephone is that my nivo slider doesnt responsive. check the site here http://www.ruskenopen.se. check it on mobile and computer. u see whats looks wrong.

  6. Andrew
    Forum Moderator
    Posted 1 year ago #

  7. webdirr
    Member
    Posted 1 year ago #

    Yes, but can I write a custom code for my nivo slider in phone css style like using max-witdh?

  8. Andrew
    Forum Moderator
    Posted 1 year ago #

    It's harder than it looks because NivoSlider adds widths to images on-the-fly. Try your best by using !important on the end of your max width styles. Also try adding width: auto !important; .

    If that doesn't work, you'll have to hack the plugin to find out where it's setting the width in jQuery.

  9. webdirr
    Member
    Posted 1 year ago #

    Than its easier to make the mobile css be like the computer css look? ;)
    if you have time sometimes u can check it out if you want. would be great if it is a function on this theme saying. mobile platform css style on and off. :)

  10. pixelstrolch
    Member
    Theme Author

    Posted 1 year ago #

    In my opinion it doesn't make sense to overwrite all the responsive code.
    I would try to make the width of the slider flexible.
    Perhaps it works with the aid of the id.

    #nivoslider-282 {
    width: auto!important;
    height: auto!important;
    }
  11. webdirr
    Member
    Posted 1 year ago #

    The last code worked!
    Used it in style.css!
    THX!

    another question. When I use the website on the phone I get like a tab say "menu". The menu is blue background and text color white. if i press this menu button a dropdown shows with my "posts-links". But there is no background color on behind these texts. How do i put in same blue color in background to that too?

  12. pixelstrolch
    Member
    Theme Author

    Posted 1 year ago #

    I would use something like this:

    .main-small-navigation {
        background-color: rgba(0, 85, 116, 0.6);
    }

    I think the readability is ok except of the hover state. You should change the color of hover text, if you go for the suggestion above.

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic

Tags

No tags yet.