WordPress.org

Ready to get started?Download WordPress

Forums

Deux Milles Douze
[resolved] Remove "leave a reply" from inside pages (9 posts)

  1. Macarena61
    Member
    Posted 1 year ago #

    Hello, I don't know how to remove "leave a reply" at the bottom of each page I create. I don't have any comment boxes checked in the settings section. Please help. Thanks!

  2. p5systems
    Member
    Posted 1 year ago #

    HI

    Comment the line <?php comments_template( '', true ); ?> in page.php.
    so it will remove the comment or leave reply optionin the pages.
    Thanks
    Chandu

  3. Macarena61
    Member
    Posted 1 year ago #

    Hi, can you please show me how to "comment the line"? I am a designer and not a programmer. Thank you!

  4. Macarena61
    Member
    Posted 1 year ago #

    Hi, I looked it up on wordpress.org and found the instructions-

    you have to put // in front of the line you don't want to show up. eg:

    The code on the page.php file was:
    <?php comments_template( '', true ); ?>

    All I had to do was insert // and now it looks like:
    <?php //comments_template( '', true ); ?>

    and the reply option no longer shows!!! :-)

  5. stevengootgeld
    Member
    Posted 1 year ago #

    I also have this problem, every new page contains "comment" "Leave a Reply" but I have found 4 files on my computer named page.php (local host of wp with wampserver) and only one of them contained that line, which I edited to no avail, the new pages I created after updating to 3.5.1 today still contain that stuff.

    Is this a bug with 3.5.1? Can anyone tell me how I can fix this?

    Many thanks for any help on this

  6. Macarena61
    Member
    Posted 1 year ago #

    Hi Steven, did you try to add the "//" like I did? Mine disappeared after I did it.

    M

  7. stevengootgeld
    Member
    Posted 1 year ago #

    Thanks, Macarena, I just found another post that told me to go to settings/discussions and uncheck some items. I deleted and recreated the pages and everything seems fine. Thanks for your reply!!

  8. Macarena61
    Member
    Posted 1 year ago #

    Great! Glad you got it working well!

  9. Zaky85
    Member
    Posted 10 months ago #

    thinks,its very work in my blog.

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic