WordPress.org

Ready to get started?Download WordPress

Forums

remove hover on header logo (4 posts)

  1. antorera
    Member
    Posted 3 years ago #

    Hello,

    For some reason, when I hover over the logo area on a site, there is a light blue background color that appears at the bottom of the logo image (about 2-3px). This is the hover background color set on the site.

    I've tried to style out the a:hover on the header logo, but I'm still getting that background color on the hover.

    This is the site affected.

    Here are the header area styles:

    /* header */
    
    #header {
      	width: 860px;
    	float: left;
    	padding: 20px;
    	background: #fff;
    }
    
    #logo {
    	width:860px;
    	float:left;
    	height: 40px;
    	margin-top: 0px;
    }
    
    #logo a {
    	background-color: none;
    }
    
    #logo a:hover {
    	text-decoration: none;
    	background-color: none;
    }
    
    #logo h1 {
    	margin-top: 3px;
    	padding-top: 15px;
    }
    
    #logo h1 a {
    	color: #000;
    	font-weight: bold;
    	text-transform: uppercase;
    	text-decoration: none;
    	font-size: 18px;
    	font-family: "Lucida Grande", "Lucida Sans Unicode", Arial, Helvetica, sans-serif;
    }

    I added the #logo a:hover style, but to no avail.

    Thanks for any suggestions.

  2. alchymyth
    The Sweeper & Moderator
    Posted 3 years ago #

    #logo a:hover {
    	text-decoration: none;
    	background-color: transparent;
    }
  3. antorera
    Member
    Posted 3 years ago #

    Lovely! That worked. Do you why the transparent worked on the background color and not "none"?

    Thanks much.

  4. alchymyth
    The Sweeper & Moderator
    Posted 3 years ago #

    'background: none;' might have worked;

    'none' is probably no valid color definition.

Topic Closed

This topic has been closed to new replies.

About this Topic