WordPress.org

Ready to get started?Download WordPress

Forums

Shashin
[resolved] Remove Facebook en Twitter link at prettyPhoto.css, link to pictures in widget (24 posts)

  1. musicfreak
    Member
    Posted 1 year ago #

    I have two questions about this nice plugin.

    First I want to remove the Facebook en Twitter link in de fullsize modus. At http://forums.no-margin-for-errors.com/discussion/1527 I read I have to edit prettyPhoto.css to set social_tools:false, but where can I find the file prettyPhoto.css?

    Furthermore I want to create a link to all my photo's at the fullsize photo of the Shashin widget. Is this possible?

    http://wordpress.org/extend/plugins/shashin/

  2. Mike Toppa
    Member
    Plugin Author

    Posted 1 year ago #

    Hi - display of the social connect buttons in prettyPhoto is handled in javascript, not css. You'll want to open shashin/public/display/shashin.js, and look for this, near the top of the file, and add "social_tools: false", like I have here (don't forget to also add a comma at the end of the previous line):

    $("a[rel^='prettyPhoto']").prettyPhoto({
                theme: shashinJs.prettyPhotoTheme,
                overlay_gallery: !!(shashinJs.prettyPhotoOverlayGallery-0),
                default_width: shashinJs.prettyPhotoDefaultWidth-0,
                default_height: shashinJs.prettyPhotoDefaultHeight-0,
                show_title: !!(shashinJs.prettyPhotoShowTitle-0),
                autoplay_slideshow: !!(shashinJs.prettyPhotoAutoplaySlideshow-0),
                slideshow: shashinJs.prettyPhotoSlideshow-0,
                social_tools: false
            });

    The same set of options is repeated further down in the file, at line 146, so you'll want to make the same update there. I'll remove the duplication in the next version of Shashin, and I've been thinking of adding this as a setting that can be managed on the Shashin settings page.

    I'm afraid I don't understand your second question - there is already a link to view the full-size version in the caption - do you mean something else?

  3. musicfreak
    Member
    Posted 1 year ago #

    Thanks! The 'social tools' have gone now! The strange thing is that they're not gone when I'm logged in in Chrome, but it works in IE and Firefox so maybee it is a caching problem or so.

    With my second quenstion I ment that if I change the 'Expanded image size' from small to medium I see a difference, but when I change it to large or X-large I don't, even not on high resolution screens.
    Sorry, my question was not that clear.

    One last thing. I have 104 photo's in a folder. , when I set the 'Default maximum number of photos to show' at 100 or 104 only the thumbnail is showing. When I set is at 90 it works, but I have to press the next button to see all photo's. Any idea what causes this?

  4. Mike Toppa
    Member
    Plugin Author

    Posted 1 year ago #

    You're probably right that the social buttons still showing up in chrome is a caching issue. See here for how to force a reload http://superuser.com/questions/220179/how-can-i-do-a-cache-refresh-in-google-chrome

    For the expanded image size, prettyPhoto tries to optimize the displayed size to fit in the available viewport (so it may be shown smaller than the size you specify in the Shashin settings). But the size you specify in Shashin is still loaded - you'll see an icon in the top right to expand it to the full size.

    For your album with 104 photos, I just tested with one of my albums that has 117 photos and it worked fine (I set the default max to 120, so they all appeared together). Can you give me a link so I can see the problem?

  5. musicfreak
    Member
    Posted 1 year ago #

    Yes, thanks, in Chrome everything is working fine now. In general thanks for all your help. I've asked maybee some stupid quenstions but you answer them as if they were very complicated. ;-)

    When I do a fresh install of Shashin, at http://wvdt.nl/shashin-test everyrhing works ok. In albums with large photo's will (such as 'Voorbereiding') the icon shows up. Also the 104 photo album shows right if I set the maximum of 110 photo's.

    The icon also shows on the private intranet site. However, since today (!!, yesterday everything works, I haven't change much) one of the albums isn't clickable anymore so I can't view the photo's. Because this is an intranet I don't want to put the URL in the open. Can I sent you an email or so?

  6. Mike Toppa
    Member
    Plugin Author

    Posted 1 year ago #

    Happy to help. You can send me an email through my contact form: http://www.toppa.com/contact

  7. musicfreak
    Member
    Posted 1 year ago #

    I've sent you an email!

  8. Mike Toppa
    Member
    Plugin Author

    Posted 1 year ago #

    I clicked the thumbnails for all 3 albums and each of them worked fine. I clicked through several of the photos in each album and they also were ok (I'm using Chrome). Is there still a problem...?

  9. musicfreak
    Member
    Posted 1 year ago #

    Nice, this morning I clicked on the three thumnails in IE and everything worked also fine.

    However when I set 'Default maximum number of photos to show' at 110 it stops working, even after I synced this album in Extra --> Shashin and also on another computer. Strange... Maybee I'll have to wait fo another day??

  10. Mike Toppa
    Member
    Plugin Author

    Posted 1 year ago #

    Now I am seeing the error. Your "Dag 1" album thumbnail is causing a server error when I click it. But without access to the server I can't see what the error is. Could you give me the Picasa (or Google+) URL for that album? Then I can add it to my copy of Shashin and I'll try to create the same error. (You can email the URL to me if you don't want to post it here).

  11. musicfreak
    Member
    Posted 1 year ago #

    Sure, I've mailed it to you!

  12. musicfreak
    Member
    Posted 1 year ago #

    I've added more photoalbums to the intranet page. All the albums works right, excerpt the Day 1 album. Strange...

  13. musicfreak
    Member
    Posted 1 year ago #

    I've split up the 104 Dagy 1 photo's. Now it works! Yes!!

  14. Mike Toppa
    Member
    Plugin Author

    Posted 1 year ago #

    Sorry I didn't have a chance to look at it today, but it sounds like you've solved it.

  15. musicfreak
    Member
    Posted 1 year ago #

    Dagy = Day :-)

    Yes, but only when I split the photo's in two so it's not a permanent solution.

  16. Mike Toppa
    Member
    Plugin Author

    Posted 1 year ago #

    Since I can't reproduce the problem with my own albums, I'd need you to put it back the way it was if you want me to diagnose it (I had a busy day yesterday so I didn't have a chance). Let me know what you'd like to do.

  17. musicfreak
    Member
    Posted 1 year ago #

    I understand, but for now I'd like that the visitors of the intranet could view the photo's of 'Day 1' the same way as the others. In a week or so I'll come back to you because I expect that there less interest in the photo's.

  18. musicfreak
    Member
    Posted 1 year ago #

    Now I have the same problem when I split the files, with the latest album that had been added.

    Can you please check the intranet link I mailed to you before?

  19. Mike Toppa
    Member
    Plugin Author

    Posted 1 year ago #

    When I log into your intranet the photos page is not there anymore

  20. musicfreak
    Member
    Posted 1 year ago #

    I'm sorry, I was forgotten to mail you. I've sent you an email with a new link.

  21. Mike Toppa
    Member
    Plugin Author

    Posted 1 year ago #

    I added some of your albums to my site, including ones that aren't loading on yours, and they are all working fine on my site.

    ...So, I have a couple questions for you:

    1. Do you have any special security on your wp-admin folder, like an .htaccess file? That could be a factor, given how WordPress does AJAX calls. Or it may be related to your intranet security settings. But it's strange that it would effect some albums but not others.

    2. Can you access your server logs? Clicking on certain album thumbnail causes a 500 server error, but I can't see any details about the error through a web browser. Your error logs would show more information about the error.

  22. musicfreak
    Member
    Posted 1 year ago #

    Yes, I have a .htaccess file, I will mail the contents to you. Furthermore a plugin called WebsiteDefender WordPress security was active, I have disabled it now.

    I don't know if I can access the server logs. I can ask my hosting provider but maybee you can tell me where you can usually find these? In DirectAdmin maybee?

  23. Mike Toppa
    Member
    Plugin Author

    Posted 1 year ago #

    My apologies for the delay replying - I've had a busy week. I just clicked through all your albums on the intranet page you set up, and everything looks like it's working fine now. Did you find the problem? I'm curious what it was.

  24. musicfreak
    Member
    Posted 1 year ago #

    I see, suddenly it works... I haven't changed anything. Very strange!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic