WordPress.org

Ready to get started?Download WordPress

Forums

WP About Author
Remove default WordPress author box (22 posts)

  1. IngmarVerheij
    Member
    Posted 1 year ago #

    You can easily remove the default author box from WordPress by adding the following CSS code (for instance via Appearance > Edit CSS):

    .author-box {
    display: none;
    }

    PS: Feature request to add this by default?

    http://wordpress.org/extend/plugins/wp-about-author/

  2. truthislight
    Member
    Posted 1 year ago #

    Thank you for sharing Ingmar. Wont that code always hide the author box? Is it possible to hide it if the description is not filled out?

  3. IngmarVerheij
    Member
    Posted 1 year ago #

    The code above will only hide the default WordPress author box, not the "WP About Author" box ;-)

    It is possible to hide the box when the description is not filled out, i've posted a solution 2 weeks ago: http://wordpress.org/support/topic/hide-authors-withouth-description

  4. Chanettk
    Member
    Posted 11 months ago #

    It didn't help for me...

    Argh!! I'm going insane in trying to completely hide that stu*** author box :)

    I'll go bald if I don't find a solution QUICK xD

  5. Rodrigo Ferreira
    Member
    Posted 11 months ago #

    Don't go bald yet, Chanettk. Try this one:

    #entry-author-info {
    display: none;
    }

  6. Chanettk
    Member
    Posted 11 months ago #

    In which file should I write it - or is it in the custom CSS form field?

  7. Chanettk
    Member
    Posted 11 months ago #

    Tried pasting it into the "Edit CSS" section, but nothing happened :(

    Any other ideas?

    Link to blog: http://michaelwith.com/blog/

  8. Rodrigo Ferreira
    Member
    Posted 11 months ago #

    Hi Chanettk,

    I've just visited your blog. You are using the theme called "Presswork".

    You have to visit Appearance > Editor > style.css

    On this page, you have to look for #authorbox and insert the following text: display: none;

    Or you can simply write the following lines at the end of this page (style.css):

    #authorbox {
    display: none;
    }

  9. Chanettk
    Member
    Posted 11 months ago #

    Rodrigo Ferreira - I am sending you kisses! It FINALLY worked. I have been looking for a solutions for weeks...

    THANKS!

  10. jonnonorton
    Member
    Posted 10 months ago #

    I'm having the exact same issue, but I am using the Admired theme. I tried all the solutions in this thread in both the custom CSS file of my theme as well as the custom CSS area provided within my theme. No luck.

    Rodrigo, would you mind taking a look at my blog and telling me what I'm doing wrong? blog.vestatrader.com (it will take forever to load, not sure why this is happening either but it could be server side, my client is hosting with a small company out of Denmark)

    Any ideas? I have a great plugin that is showing my authors' info already, so I just want to get that default area out of there.

  11. Rodrigo Ferreira
    Member
    Posted 10 months ago #

    Hello Jonnonorton,

    Try to use the following code on the custom CSS area provided within your theme:

    #author-info {
    display: none;
    }

  12. jonnonorton
    Member
    Posted 10 months ago #

    That worked perfectly Rodrigo. Thank you so much for helping me :)

  13. Medievaldragon
    Member
    Posted 9 months ago #

    I'm not a programmer or coder.

    I added all the codes mentioned in this page in the:

    Appearance --> Editor --> User.css

    None of these codes worked for me on the Arras Theme 1.5.3

    I'm a "observe. Trial and Error. Repeat" type of guy to counter the lack of coding knowledge.

    ATTENTION

    I will provide here two scenarios.

    Scenario # 1:

    In my case, I have the "Custom About Author" plugin installed. This caused me to have TWO About author blocks displayed. The custom one, and the default one. Annoying, I know.

    My fix was this:

    In your Dashboard menu go to Appearance --> Editor --> Single Post (single.php)

    In the Single Post editor find the following text:

    <?php
    if ( arras_get_option('display_author') ) {
    arras_post_aboutauthor();
    }
    ?>

    Once you locate that piece of code, add the following tags:

    <!-- <?php
    if ( arras_get_option('display_author') ) {
    arras_post_aboutauthor();
    }
    ?> -->

    This will make the "About Author" box invisible. If you wish to restore it simply remove the tags.

    <!-- -->

    Scenario # 2

    There is a very easy way to remove your About Author. Simply go to the admin dashboard.

    On the top-right corner you will see "Howdy, Your-username". Click it and choose the "Edit my profile" option.

    At the bottom of the page checkmark this option:

    "Disable about author display (Check this box to not have author's profile displayed at bottom of each post.)"

  14. jonnonorton
    Member
    Posted 9 months ago #

    Medievaldragon, you need to put a lot of this code into places other than the user.css file. That's probably why they didn't work for you.

    For example, the fix that worked for me required me to enter the code into the Custom CSS area of my theme. I didn't need to use the edit theme area at all, which is where the files you're talking about are stored.

    Try making sure you use the fixes in the correct area of your WP site and you may have better luck with the solutions provided on this page. I know I was having the exact same problem you described and it was fixed with Rodrigo's last post. Your theme is different than the one I'm working on with this client, but it may be worth trying it the way it was described to see if it works for you.

  15. jonnonorton
    Member
    Posted 9 months ago #

    Also, the box you are talking about in your solution #2 is actually a box that is provided by the third party plugin you installed to feature your authors. I don't think that's a default wordpress feature. When I checked that box it turned off my new author boxes which I actually wanted to view. As info

  16. AAPS News Editor
    Member
    Posted 9 months ago #

    Hi I could really use some help. I have the same problem with author boxes showing up and I can't get rid of them! For example: http://news.a2schools.org/videos-slideshows/

    I've tried some of the suggestions I've seen above, and the theme developers (MH Magazine Premium) don't know how to fix it.

    Please help!

  17. fabriziomartini
    Member
    Posted 7 months ago #

    Hi! I'm using Hiero theme... can you help me to remove that annoying default wordpress author info?
    I tried to add in style.css, but nothing happens!
    #author-info {
    display: none;
    }

  18. esmi
    Theme Diva & Forum Moderator
    Posted 7 months ago #

    @fabriziomartini: Please continue with your existing topic.
    http://wordpress.org/support/topic/i-have-a-problem-with-the-author-box?replies=1

  19. Rodrigo Ferreira
    Member
    Posted 7 months ago #

    Hello fabriziomartini,

    You should try this one:

    .author-info {
    display: none;
    }

    I think it shoud do it.

  20. fabriziomartini
    Member
    Posted 7 months ago #

    I tried it... but it doesn't work. I added that code on style.css

    Is that right?

  21. zupadream
    Member
    Posted 4 months ago #

    Hi there,

    I use the fancier author box on my blog and it's awesome, I want to keep it. I know how to get rid of that one, but it is a second one which appears only for myself (not with blogs of my contributing authours). This is the one I want to get rid off and it is driving me craaazy I can't find it....

    it would be FANTASTIC if you could help out :)

    here a link for you to see the problem:

    http://www.zupadream.com/marble-cake-cherries/

    Thank you!

  22. letianmoon
    Member
    Posted 3 months ago #

    I have the same question,I want to use fancier author box but there is another one appears under the post like this
    http://easyhairstyleideas.com/short-hairstyles-black-women.html
    I need some help.Thank you!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.