WordPress.org

Ready to get started?Download WordPress

Forums

Adventure Journal
Remove 'Comments Off' and 'Comments are Closed' (5 posts)

  1. saraohara
    Member
    Posted 1 year ago #

    I've tried all the normal ways and editing css as suggested in this forum - with no success. Read this problem was supposed to be fixed with 1.7 update but I just uploaded the Theme and it's 1.7.2.

    Thanks for any help - lovely Theme except for this issue!

    http://wordpress.org/extend/themes/adventure-journal/

  2. alchymyth
    The Sweeper & Moderator
    Posted 1 year ago #

    in comments.php, find:

    <p class="nocomments"><?php _e( 'Comments are closed.', 'adventurejournal' ); ?></p>

    remove as much as you like;
    btw:
    the common css fix .nocomments { display: none; } should have worked.

    in loop.php (does occur more than once, change all), find:

    <span class="comments-link"><?php comments_popup_link( __( 'Leave a comment', 'adventurejournal' ), __( '1 Comment', 'adventurejournal' ), __( '% Comments', 'adventurejournal' ) ); ?></span>

    change that to:
    <span class="comments-link"><?php comments_popup_link( __( 'Leave a comment', 'adventurejournal' ), __( '1 Comment', 'adventurejournal' ), __( '% Comments', 'adventurejournal' ),'','' ); ?></span>

    this adds the fifth parameter as an empty string to overwrite the default 'Comments Off' - http://codex.wordpress.org/Function_Reference/comments_popup_link

  3. saraohara
    Member
    Posted 1 year ago #

    Thanks for the quick response but...still get Comments None or Comments Off
    1. Tried easiest, adding to CSS
    2. Tried removing just text from comments.php and then the whole code: <p class="nocomments"><?php _e( 'Comments are closed.', 'adventurejournal' ); ?></p>
    3. Tried the replacement code in loop.php

    Any other suggestions?
    In gratitude!

  4. alchymyth
    The Sweeper & Moderator
    Posted 1 year ago #

    but...still get Comments None or Comments Off

    please post a link to the pages where the 'comments ...' text appears.

    have you cleared all caches, including browser cache?

    also, double check that the edited files are actually on the server in the actual themes folder.

  5. saraohara
    Member
    Posted 1 year ago #

    Well, I did clear cache etc. yesterday - even changed Themes, deleted Adventure Journal and then installed it again - with no luck. So I installed a different Theme.

    THEN TODAY I changed back to Adventure Journal and now it's good! I was surprised it kept my code changes - or it seems to have because I see just 1 instance of where I changed the code in loop.php (and NOW I see you said it will appear several times and to change all! Changing just one seems ok.

    Here's the test site - if my client does choose this Theme I will copy this code! http://www.saraohara.com/wp8/

    Thanks so much!

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic