WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Remove Comments from Specific Pages in twenty ten 1.2 wordpress theme (9 posts)

  1. Davina2010
    Member
    Posted 2 years ago #

    I could use your help. Please go to the following page to see the problem.--

    http://www.popelawtx.com/blog/resume/

    Ok, clearly, I do not want comments on this page and the other pages I will be working on that are not blog pages.

    For this theme "twenty ten 1.2" how do I do this?? I know how to go to discussion and take the "check" off comments but I believe that takes it off of all pages. So how do I do it for specific pages. I am not so good with Word Press yet.

    I would appreciate any help you can give me!

  2. Rev. Voodoo
    Volunteer Moderator
    Posted 2 years ago #

    activate the appropriate discussion and trackback/pingback sections within the post/page editing screen from the screen options tab

    You can then turn them off per post/page

  3. Davina2010
    Member
    Posted 2 years ago #

    I don't want the person reading the page to be able to make comments.

    When I activated the appropriate discussion and trackback/pingback sections within the post/page editing screen from the screen options tab

    You can then turn them off per post/page

    This only made a change to the editing of the page not what the reader was seeing.

    This didn't work for me. Any other ideas??

  4. esmi
    Forum Moderator
    Posted 2 years ago #

    Uncheck "allow comments" in the Discussions pane in Edit Page.

  5. Rev. Voodoo
    Volunteer Moderator
    Posted 2 years ago #

    From the add new page screen

    I click on 'screen options' which drops down a menu

    Within that menu, one of the choices is discussion. If I check discussion, it adds a new box under the editor.

    Within that new box, are 2 options

    Allow comments.
    Allow trackbacks and pingbacks on this page.

    If I uncheck those 2 boxes, and then save the post/page, comments are no longer allowed on that particular post. As in, the person reading the page no longer has the option to make comments. The comment section is gone for that post/page

  6. Davina2010
    Member
    Posted 2 years ago #

    Ok, I think I got it. This is what I did--

    I went to the "Pages" page and clicked on the "quick edit" option for each page and there I could uncheck the Comments option. I think that did it.

    I just checked it out and it worked.

    @ESMI--I never saw the "discussion pane" when I was in the edit page mode.

    Rev. Voodoo--going to screen options never worked for me either.

    I think it all depends on what "theme" you are using but I could be completely wrong. It seems like each one has different options and features and how it works. Somethings are similiar it just depends on what exactly you are doing.

    Thank you two so much for all your help!!

  7. Rev. Voodoo
    Volunteer Moderator
    Posted 2 years ago #

    It actually has nothing to do with the theme you are using!

    The discussion panel is wordpress core.

    The quick edit thing you just did has the same effect as using the discussion panel under a post. (except, not sure if it turns off track/ping backs.... which look messy)

    I'll try to show you what I was referring to, if you don't have these options, then something is missing from your install, either due to a plugin conflict, a theme conflict, or something....

    So, I went to Pages -> Add New (also works for Posts -> Add New)

    And clicked screen options (top right corner) http://vudu.me/screenoptions

    Next, turned on Discussion (Again look top right) http://vudu.me/discussion

    And finally, the panel (big red arrow)
    http://vudu.me/panel

    Uncheck both those boxes to turn off all commenting

  8. Davina2010
    Member
    Posted 2 years ago #

    Thanks so much Rev. Voodoo I see what you are saying and checked it out. You are correct and thank you for your wisdom with this issue!!

  9. Rev. Voodoo
    Volunteer Moderator
    Posted 2 years ago #

    For sure! Glad I was able to help

Topic Closed

This topic has been closed to new replies.

About this Topic