WordPress.org

Ready to get started?Download WordPress

Forums

Preference Lite
[resolved] Removal of Comments on Articles / Pages (6 posts)

  1. TGAOTU
    Member
    Posted 1 year ago #

    I have recently switched to the Preference Lite and I do not want people to comment on any of the articles that I put up.

    I have went into the settings and changed the Discussion to where basically everything is UNCHECKED. But it still places comment boxes on the bottom of my articles.

    Website is CpaDavidBrown.com

    Thank you for your assistance

  2. StyledThemes
    Member
    Theme Author

    Posted 1 year ago #

    Actually, I believe to disable comments is done on a per post and page basis because there is no "disable' comments option in the WP settings (although there really should be). With a page or post open in the editor, at the top of the screen is a tab "Screen options" where you can enable the comments and discussion, and then at the bottom of the editor, uncheck the boxes.

  3. Rommel
    Member
    Posted 1 year ago #

    Hi StyledThemes,

    Can you help me on my post please?

    Here is the post link
    http://wordpress.org/support/topic/how-to-add-dybnmic-sidebar-on-walker-nav-menu?replies=1

    Thanks very much

  4. TGAOTU
    Member
    Posted 1 year ago #

    Yeah I searched the Screen Options as well and everything is unchecked. Its funny because the about me page does not have it but all other pages does include the Add a Comment..

    Any Ideas?

  5. TGAOTU
    Member
    Posted 1 year ago #

    Actually I just stumbled upon the answer by accident. On the about me the Template was set to Full Width Page Template and all others for some reason were set to Defualt Template.

    I changed all to the Full Width Page Template option and they have removed the Add a comment section on all those pages...

    Do you know what the difference was?

  6. StyledThemes
    Member
    Theme Author

    Posted 1 year ago #

    Actually I do... I just opened the file and it looks like I forgot to uncomment the comment code (meaning it won't show at all regardless). IT should actually be uncommented and available, so I will have to change this when I do the next update for the theme.

    Anyway, for pages, I just tested this locally on my test site and by unchecking/checking the comments option, I was able to show or hide the comments.

    For posts, if you do the same, the comments form will show or hide, but the way WordPress works is that if you have existing comments already published, these will show.

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic

Tags

No tags yet.