WordPress.org

Ready to get started?Download WordPress

Forums

Multiple content blocks
[resolved] "remote http" error for drafts, no multiple content blocks for published posts (4 posts)

  1. Steven Vachon
    Member
    Posted 1 year ago #

    Here is the exact error:

    Your server doesn't allow remote HTTP requests using wp_remote_get. You will have to visit this page manually to update which blocks are used on each page.

    The "visit this page" link leads to a 404 before saving or publishing. When saved as a draft, the link goes to a preview of the post. When published, the error and the "Multiple content blocks" collapsable box surrounding it do not appear. So, there is no way for me to use this plugin on my posts/pages.

    http://wordpress.org/extend/plugins/multiple-content-blocks/

  2. kthms
    Member
    Posted 1 year ago #

    Sorry, I'm not here to help, as I have the same issue. Well, this plugin works just fine on pages, but even though I haven't added code on index.php, it's popping up on my posts (and sadly, when I try to add a new slideshow on Portfolio Slideshow Pro!)

  3. Trendwerk
    Member
    Plugin Author

    Posted 1 year ago #

    This error is caused when your server doesn't support HTTP requests. MCB relies on HTTP requests to find out which content blocks should be used.

    Your errors seem a little strange though. I will see if I can recreate them, I'll get back to you.

  4. Trendwerk
    Member
    Plugin Author

    Posted 10 months ago #

    In case HTTP Requests don't work, automatic initialization of blocks is not possible.

    I've just added an admin page where you can disable HTTP requests. You can refresh the blocks manually by visiting the page.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.