WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
Rel="author" disappeared from the homepage (21 posts)

  1. utnalove
    Member
    Posted 1 year ago #

    WordPress version: 3.4.2
    WordPress SEO version: 1.4.1

    I did this: half year ago I set the plugin to show the google plus author in the homepage. I set the right google plus URL from the wp-admin/users and of course from ../wp-admin/admin.php?page=wpseo_titles#top#home

    It was working fine. The google rich snippet test tool gave the green light and everything worked fine since january/february. And since few weeks ago I could see the google plus data from the search results for the homepage.

    I expected the plugin to do this: To keep working fine.

    Instead it did this: It stopped to add the rel="author" from the homepage. I have tried to disable the cache plugin, disable/enable wordpress SEO, I also tried to do not show the author from the homepage and set it back on. But nothing. The rel="author" keeps working on the posts, but not on the homepage. Also google says "Authorship is not working for this webpage."

    What can I do? The site is glamourina.pl

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. rafikipress
    Member
    Posted 1 year ago #

    I have exactly the same problem and I am 100% sure that it is WordPress SEO that is causing Google Athorship not to work on the homepage. Disabled all other plugins, same result. Disabled and enabled WordPress SEO, and I get the error when it is enabled. Enabled and disabled the Author settings on the Social Screen of the plugin. Breaks authorship irrespective of whether a user is selected as author.

  3. utnalove
    Member
    Posted 1 year ago #

    Yes it is's SEO the same here.
    However it looks like the only difference is that in my case I do not see any error when I turn on/off the plugin. Just the rel author is missing in the homepage.

    I have added the following manually while waiting for the support:

    <?php if ( is_home() ) { ?>
    <!-- for yoast's support - I have added this manually, because the plugin is not adding it - please help -->
    <link rel="author" href="https://plus.google.com/XXX" />
    <?php }  else { ?>
    <?php
    }
    ?>
  4. dgslaw
    Member
    Posted 1 year ago #

    WordPress version: 3.5.1.
    Wordpress SEO version: 1.4.3

    I have the same problem. I use WordPress SEO on multiple websites. On at least 3 websites I've also used author highlighting on the homepage.

    This used to work fine. I've seen nice Google Plus pictures in the SEO results. However, since a couple of months author highlighting on the homepage has stopped working. The <link rel="author">-line disappeared from the source of the front page.

    I tried disabling all (caching)plugins, changing the theme back to the default theme, disabling Cloud Flare. I also tried changing the homepage of my website from a static page to a blog roll.
    All without effect.

    It appears to me, although I am not sure, this problem started after updating to version 1.3.4.4. of WordPress SEO. The changelog states:

    - Improved logic for rel=publisher on frontpage.

    Maybe a little bug snug in this improvement?

    I hardcoded the <link>-line in my theme for now, but hopefully Yoast has a solution for this problem, because this option was great!

    Thank you very much in advance.

    Websites:
    mode-recht.nl
    speelgoedrecht.nl
    werkrecht.nl

  5. squidgydesigns
    Member
    Posted 1 year ago #

    Hi,

    It's taken me a while to figure out but I too am having the same problem!

    Does anyone know if Yoast has been informed?

    Thanks

    Andy

  6. utnalove
    Member
    Posted 1 year ago #

    I also thinks this problem happened when the rel="publisher" appeared in the settings. Not 100% sure btw.

    I am sure Yoast reads the support tickets, maybe not every day. For now you can put in the header the code I posted above. It's a temporary workaround.

    Let's wait for Yoast to reply, for sure he is very busy...

  7. squidgydesigns
    Member
    Posted 1 year ago #

    Thanks...

    I'm a designer not a coder... did you put the above code in header.php?

  8. utnalove
    Member
    Posted 1 year ago #

    squidgydesigns, yes, before the </head>. And of course change the href="https://plus.google.com/XXX" with the real URL of you Google Plus profile.

  9. JGreene
    Member
    Posted 1 year ago #

    Experiencing the same problem here. Definitely connected to a conflict with rel=”publisher” settings within the plugin. Proper rel=”author” for homepage reappeared once I deleted our Google Publisher Page URL from WordPress SEO.

  10. james_str
    Member
    Posted 1 year ago #

    Same problem here, once again. :(
    Whats going on with that latest upgrade???

  11. utnalove
    Member
    Posted 1 year ago #

    I've just installed the newest upgrade, but I can see that the problem has not been resolved yet. :(

  12. mortaz1
    Member
    Posted 1 year ago #

    Hi folks - re=author is not working for us and we have identical rel=author and rel=publisher HTML source code for our posts showing in this Yoast WP SEO plugin section! However, some posts do show up with the photo in snippet and some don't show the photo (from Google Plus)

    We are baffled as to why the SAME identical HTML code from this plugin behaves differently on different posts. I have compered them side by side inside an Excel spreasheet! rel=author and rel=publiher have identical Google Plus profile in them, but one works, the other does NOT!

    Help, please.....

  13. Andras Hahn
    Member
    Posted 12 months ago #

    Dashboard -> SEO -> Social -> Google+ -> Author for homepage -> Select your profile

  14. Chad Eisenhart
    Member
    Posted 8 months ago #

    The above post does the trick - but if anyone wants a more visual and detailed approach I wrote a post

    http://www.seo-911.com/rel-author-working-on-all-but-home-page/

    Making the change solved the problem.

  15. guitardaddy76
    Member
    Posted 5 months ago #

    What if the dropdown menu does not allow me to choose my own user profile? Is there a setting I'm missing?

  16. Gary Bairead
    Member
    Posted 5 months ago #

    Rel="author" should only be used on posts, not blog indexes or archives.

    See this for more info on why, and how to use Yoasts plugin - http://moz.com/ugc/google-plus-authorship-one-critical-thing-you-need-to-know

    In short, Google+ authorship should be used only on blog posts and other individually-authored content on websites -- and not on home pages, product pages, informational pages, contact pages, and so on.

  17. Gary Bairead
    Member
    Posted 5 months ago #

    The default settings in the plugin will be updated to reflect the issue in my last comment - https://github.com/Yoast/wordpress-seo/issues/652

  18. utnalove
    Member
    Posted 5 months ago #

    Hi Gary,

    what you say (that it should not appear in the homepage) makes sense.

    However... is there an official document from Google that confirms it and you can give us the link to? Or it is just a theory and personal opinion (which I agree to, but still it is my opinion)?

  19. Gary Bairead
    Member
    Posted 5 months ago #

    it's not my personal opinion.

    If you actually read the links in my previous comments to Github and Moz, you'll see where the info comes from on Google, how it was confirmed by the experience of a writer for Moz.com, Joosts response to that article, and the Github issue he opened about changing the defaults in his plugin.

    I'm not sure what more info you need.

  20. utnalove
    Member
    Posted 5 months ago #

    Ideally? I would like to read about it somewhere here https://support.google.com/webmasters/

  21. Gary Bairead
    Member
    Posted 4 months ago #

    Are you unable to read the content in the link I've posted for some reason ?

    It both quotes and links to content from the Google Webmaster Central blog.

    If you're having trouble seeing it, I've created a screenshot with arrows pointing towards the link to the Google Webmaster Central Blog and the text that's taken from it - https://www.evernote.com/shard/s66/sh/b2f561d8-d1f5-472b-8d1c-eec6932fa1b4/eb963cfe516bdeb0a1512fb8e02f3532/deep/0/Google-Plus-Authorship--One-Critical-Thing-You-Need-to-Know---YouMoz---Moz.png

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic